Web Server Behind Router

By Big-Z ยท 14 replies
Apr 7, 2005
  1. Hi,

    Thanks to every1 who help me for the last prob. This time, I want to host my own web space. I have a domain and it points to my ip, this is not a prob. The problem is that when u type the web address, it brings up my router's web server/config util. I've set the router up to forward port 80 to (web server) and I have configured IIS on the web server to show my test page. The web server works on the LAN and I know the problem is with the router. I have a D-Link 504T modem router, and I'm really not sure what the problem is. There are no virtual server settings on the router, there is only a port forwarding option.

  2. HoopaJoop

    HoopaJoop TS Rookie Posts: 90

    Are you testing it from outside your lan?

    Some routers, especially those with firewall capabilities don't traffic that exits the router for something behind it. I haven't had a chance to take a look at your router though.

    Are you forwarding TCP and UDP to your internal web server? If the traffic being forwarded is a protocol you aren't forwarding all traffic will stop at the router.

    Also, if you are getting the config page for your router on your outside interface you may want to fix that before you publish a server to the outside.

    Hope this helps.
  3. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    As HoopaJoop said, if your external IP/hostname brings up your router configuration then you have a serious security issue. Disable the external management of the router immediately! Once you have done that your port forwarding should start working too.
  4. Big-Z

    Big-Z TS Rookie Topic Starter

    Yeah, I normally like to try and figure something out, but becuase of the security issue I thought it best to get sorted right away. I'm not sure if I can disable the external config.

    The only time I get this prob is when I try to connect from outside the LAN. The web server works from inside the LAN.
  5. Big-Z

    Big-Z TS Rookie Topic Starter

    Also, if anyone can suggest how to disable config util on router that would be cool
  6. Big-Z

    Big-Z TS Rookie Topic Starter

    Also, I am forwarding both TCP and UDP to local address
  7. HoopaJoop

    HoopaJoop TS Rookie Posts: 90

    On the 'Tools' tab of the 'Admin' screen disable "Remote Web Management" and "Remote Telnet Management".

    It's in the manual. Check it out here.

    hope this helps.
  8. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    If you are hosting your own server
    physical box in front of you
    got a dsl or cable setup
    check to see if they allow port 80 cut through
    personnal accounts for sure big no
    who ever you signed up with (manage your domain name)
    should have a place to put your dns that your isp gave you
    check in router (status)
    like mine m7l.com points to my ip
    still can't get the connect add ( :8500/ )
    this is for my open port you could use other numbers like 8080
    I changed the www. to workstation1 plus others ebay foo file
  9. Big-Z

    Big-Z TS Rookie Topic Starter

    There has been a development. Thanks to all who have replied, unfortunately, it just kinda resolved itself. Now, people accessing the site externally get my web page (hooray!). But, I can only access it through the LAN as when I type the external IP I get the router screen (need to flush the cache or summin and don't know how to do it if it aint deleting all my cookies or temp inet files)

    For everyone's info, remote management was turned off originally, even when external access attempts brought up the router screen. So I don't really know what was going on. It just sorted itself out... :suspiciou

    Thanks to all who replied

  10. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You probably have a stupid router that cannot handle loopback connections properly.
  11. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You probably have a stupid router that cannot handle loopback connections properly.
    You should be able to see your own webpage if you use your ISP's web proxy.
  12. danielb

    danielb TS Rookie Posts: 19

    Hi people i have the same problem as this chap with the same router. I here its normal and have to use a proxy server. It works fine for outside my lan, but i need to test everything works when i change stuff. Any chance i can get his email or admin forward a message so i can chat to him? i left him a private message but he's only posted 22 in the last 6 months.

  13. skarr666

    skarr666 TS Rookie

    Work around here.


    I had the same prob with my lame Actiontec 1524,.. no loopback.

    Two ways I worked around,.. to the server and make sure it is working I did these two things:

    1. You can use Googles Translate page,.. it worked for me,. just to let me know the server was functioning. It is kinda like viewing the server on the other side of the router. Just put your url in the field and check it out..


    2. I edited my hosts file. You can do this in windows or linux,. only thing is that you dont know if your dns goes down.. but it is a good way to check the server on the dark side of the router :) Aside from phisically checking from another source. Providing you have your dns setup correctly, server running, port forwarding setup (port 80 forwarded to the machine ip that is serving, via the router) you can do this:

    emacs /etc/hosts

    (add your server/the ip is the servers ip)
    192.168.x.x yourdomain.com
    192.168.x.x www.yourdomain.com

    Windows: (do a search for a howto)

    I hope this helps.
  14. patio

    patio TS Guru Posts: 482

    Anyone having the same problem should start a new thread as each situation can have tons of variables...
    And Welcome Aboard.

    patio. :cool:
  15. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Skarr's post was absolutely relevant. As he said, routers being unable to do loopback connections are pretty common and it is the first thing to check when someone can't connect to their own servers.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...