1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Weird BSOD and crazy minidumps

By Daveskater ยท 7 replies
Oct 17, 2007
  1. Hi, my friend came over to me today because his laptop started giving BSOD's and was logging on really slowly. The pc has never connected to the internet and all he really does with it is put music on and off and record his own music.

    The strange thing about the BSOD's is that the screen goes blue and instead of writing it's just a load of lines and shapes like the picture's been distorted.

    I've attached all the minidumps to see if anybody else can make anything of them because when i open them it has a load of random symbols and then a bit of text that i can't decipher - it looks like a list of services or processes. I tried opening them in Word 2007 and looking through the encoding options but it just said "PAGE" over and over again for about 250 pages.

    I also ran HJT just in case there was something causing the problem there and there was an O4 entry that was like "[????????] ??????????e" so i fixed it and then pc then logged on faster but still BSOD's. It's stable in safe mode so i can run scans etc so let me know if i should run any other programs.

    If anybody can get anything out of the minidumps and tell me what the problem is then i'd be grateful.

    Also i've attached the HJT log just for reference and if anyone wants to take a look.

    Edit: each time the pc starts the weird O4 entry comes back so i'm going to go through the preliminary removal instructions and i'll post logs up. Even though the laptop has never had the internet, it must have gotten something bad on it over a usb flash drive.

    Attached Files:

  2. Rik

    Rik Banned Posts: 3,814

    I'd say its more likely to be a hardware rather than a software fault.

    Google and get memtest and run it for atleast 7 passes.

    Then get the diagnostics software from the hard drive manufacturer and test the hdd out.
  3. Daveskater

    Daveskater Banned Topic Starter Posts: 1,687

    ok, i think i have the memtest files on my pc somewhere but i don't think it's the memtest+ version, it's the memtest 3.3 one

    i got a bit suspicious of the hjt entry so didn't really think of hardware :) i'll give memtest a go though

    oh yeah, norton and a load of junk such as yahoo toolbar was on the pc because it's an acer so i took them off and i've put spybot, ccleaner and avg on
  4. peterdiva

    peterdiva TechSpot Ambassador Posts: 1,088

    You've got a registry problem. All the dumps are crashed with bugcheck 51. Did the crashes start before or after removing the junk?

    BugCheck 51, {1, 854238b0, ca7000, 368}
    Probably caused by : ntkrnlpa.exe ( nt!CmpFreeKeyByCell+55 )

    Something has gone badly wrong with the registry. If a kernel debugger is available, get a stack trace. It can also indicate that the registry got an I/O error while trying to read one of its files, so it can be caused by hardware problems or filesystem corruption.
    It may occur due to a failure in a refresh operation, which is used only in by the security system, and then only when resource limits are encountered.
  5. Daveskater

    Daveskater Banned Topic Starter Posts: 1,687

    it started before i did anything to the pc

    my friend was using it and said he went back to it after using it for a couple of hours with no problems then it started bsod'ing

    i've managed to do a system restore and it seems to be ok now but should i run some sort of registry check anyway?
  6. peterdiva

    peterdiva TechSpot Ambassador Posts: 1,088

    No. Just leave it and see how things go.
  7. Daveskater

    Daveskater Banned Topic Starter Posts: 1,687

    ok :)

    i'm trying to install avg (it wouldn't in safe mode because it couldn't start services) but it gets stuck on the same service each time

    could this be because the system restore has brought norton back? - it's in the add/remove programs list again
  8. Daveskater

    Daveskater Banned Topic Starter Posts: 1,687

    i'm not sure whether to start a new thread on this or not but i can't uninstall avast AV

    i couldn't get avg to work so tried avast which installed fine, but won't run

    each time it tries to load it comes up with the thing that says it has stopped working and needs to be closed (the pc is running vista home premium)

    i've tried uninstalling it through add/remove programs but it crashes then as well, it does the same in safe mode

    i've now put kaspersky on which is working fine (running a scan as i speak) and i'm using the pc now without any problems

    if anybody has any ideas or can tel me how to uninstall it the hard way then it'd help me out a lot.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...