1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Weird file-transfer problem with Flash drive

By LeonE · 6 replies
Dec 11, 2006
  1. Hi all

    The other day I bought my dad a flash drive (Kingston, 2 Gb) for him to back-up all his files. There are about 180 files, all either MS Word, Access or Excel documents and in total come to around 50 Mb.

    I selected alll files in the relevant folder and dragged/dropped to the flash drive. To cut a long story short, I managed to copy all apart from 17 of them. For some reason whenever I try one of these 17 I get the message "Unable to copy [filename]. The file could not be created." or words to that effect.

    These 17 files seem no different from any of those that were copied succesfully- they're the same format, created on the same PC with the same software. They can all be accessed/edited ok and so are not obviously corrupt. I tried creating a new file and copying info from one of the rogue 17 into this, them copying the new file across to the flash drive, but I get the same error. I thought this must mean there's something wrong with the data/how it's been entered but it seems to be exactly the same format/arrangement as the data in the files that have copied ok.

    Does anybody know what's going on?
  2. dopefisher

    dopefisher TS Rookie Posts: 436

    Did you accidentally turn on the write protection switch on the flash drive?
  3. LeonE

    LeonE TS Rookie Topic Starter Posts: 17

    I wish it were that simple, but unfortunately no.
  4. suzgleason

    suzgleason TS Rookie

    i jusst joined this group because I am having the exact same problem. Just bought a Kingston 2GB USB Data Traveler and I am uploading jpeg pics and get 3/4 of the way through and it says : "Cannot copy" " The directory or file cannot be created"

    What does this mean? The drive is not filled to capacity and will not be filled with this data move into it.
  5. tipstir

    tipstir TS Ambassador Posts: 2,842   +193

    You can check to see how much space you have on the 2GB more like 1.8GB would be free on average. If you have more than that for JPEG images then you're going to get that error message above.
  6. LeonE

    LeonE TS Rookie Topic Starter Posts: 17

    It's been a while since I started this thread but I thought I'd post back because I managed to solve this problem:

    I simply created a new folder/directory on the Kingston flash drive and copied the files into that i.e. the drive showed on my dad's PC as G:, so rather than copying the files from his desktop to G: I was copying them to G:\New Folder. I have no idea why this would work, but it did for me!
  7. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,547   +432

    There are limits on how many files you can have in the root directory. Did you have a bunch there when this problem occured?
Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...