Why Won't You Work Sata???

By raab ยท 4 replies
Dec 30, 2004
  1. Hello...I spent the whole of today...12pm - 22:45pm researching on the internet on how to get this drive working. It's a DiamondMax Plus10 250GB SATA drive.

    System spec.
    barton 2800xp
    512mb ddr
    powercolor radeon 9800pro
    Asus A7N8X Deluxe
    2 IDE HDD's already installed
    Windows 2000 professional

    So the SATA is onboard but wouldn't show up in BIOS as anything.
    I installed the Silicon drivers from the website and changed the SATA jumpers on the board and windows booted up found a new...thing (didn't see exactly what) and installed it fine.

    It shows up in device manager under SCSI and RAID controllers > Silicon Image SiL 3112 SATARaid Controller. When you double click it says "This device is working properly." in the grey box.

    But it doesn't show up in "My Computer" or a program i downloaded "DiscWizard" OR in "Disc Managment".

    I updated BIOS and it now shows something about boot sequence for SATA and SCSI. So i put it as boot from SATA then SCSI (rather than SCSI then SATA). That was the only updated thing i could see.

    Still not showing up in "My Computer".

    Although while booting up the computer, after it's detected all the IDE optical devices and checked the RAM etc. it comes up with something about launching the SATARaid Utility, if you leave it it continues to boot, if you click "F4" as it asks it does a check then says there's no device or something then "disables" it.


    Thanks in advance Raab.
  2. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    So, your machine is not recognising the HDD at all? If its new, sounds like you have a faulty HDD. Is there more than one SATA port you can try? Do you have a spare cable? In any case, it sounds like the drive is not spinning up.
  3. raab

    raab TS Rookie Topic Starter

    i've tried both of my 2 sata ports on my mobo. and it could be faulty but i don't understand why after setting the SATA jumpers to "enabled" it came up with found new hardware when i booted windows
  4. Wilmeland

    Wilmeland TS Rookie

    try after the first

    could be the "Sata Clause" - maybe just processor bound from the holidays

    Try re-installing next week.
  5. raab

    raab TS Rookie Topic Starter

    thanks guys...problem was - you know the little cables that go into the plastic connecter for hte power cable? well ONE of those tiny wires was a little loose. Shoved it in and the drive fired up nicely.

    stupid problem that's cost me 2 days of my life but nevermind...
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...