Windows 2000 oddness

By zebazga
Oct 5, 2005
  1. I made the mistake of trying to remove Internet Explorer from Windows 2000. I more or less followed the Microsoft Technet article 293907 which says remove it through Add/Remove programs. I follwed the advice in that article and when IE wasn't in add/remove programs, I ran w2kexcp.exe /u from the Internet Explorer\IE Uninstall folder from a command line.

    While running w2kexcep.exe it got about 3/4 through and then said something like it couldn't restore previous version and failed.

    I conceded defeat and resinstalled IE 6 with sp latest and the various MS updates.

    Since then I've so far found the following behaviour (and also rebooted several times):

    • When I double click Add/Remove Programs in Control Panel nothing happens.
    • I cannot move icons from my desktop, though I seem to be able to delete them.
    • I cannot copy or move files in Windows explorer.

    What can I do to fix what ever I (or MS) managed to muck up?

    Thanks for any help.
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    Maybe doing a repair install of Windows 2000 will help.

    Instructions for the above, can be found HERE

    After doing the repair, you will need to update your Windows again, as the repair will wipe all your current Windows updates.

    Regards Howard :wave: :wave:
  3. zebazga

    zebazga TS Rookie Topic Starter

    Thanks for your reply, Howard. After not coming up with any other ideas, I finally broke down and did the repair. By the way, why not go through the recovery console?

    Towards the end I got the following error:

    Subcomponent Com+ raised an exception while processing the OC_COMPLETE_INSTALLATION setup message ..\csetuputil.cpp (line 3419) Error Code = 08007007f. The specified procedure could not be found. Failed to load the library 'C:\WINNT\system32\comcvcs.dll'

    Things finished though, and it went through and refound and reinstalled all my devices and drivers. I though it saving my setting meant the devices/drivers would be saved? Anyway, it did that and then I installed the 50 kagillion SPs, FPs, critical updates, etc.

    Everything is back to running fine, can copy files, Add/Remove Programs works, etc. so I figured the above error's not relevant.

    However, there's a new problem. It's a minor one, but the graphics are different in Age of Mythology. The first time I ran AoM I got an error saying that a procedure entry point couldn't be located in gd132.dll. Goggled and found a deal saying that an XP driver had been installed instead of the 2000 one. I switched to the 2000 driver and it worked. Cept for the graphics.

    Actually, only the graphics for water. Everything else is the same as it ever was, but the water is now just a teal color with a rounded line where it hits the shore. Previously the water was shaded and close to shore you could see the bottom of the ocean/sea/whatever, and a person could walk on the shore and partially be in the water.

    I updated the Direct X version to see if that helped, and it didn't. When I ran the Windows 2000 repair, is there any reason it would pick up XP files? Or existing programs switch from 2000 to XP files?

    Figure this is a long shot, but since I wanted to update what had happened anyway, though I'd pour my heart out. Thanks again for the help.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...