windows default driver usb hdd problem

By neon256 ยท 4 replies
Apr 10, 2005
  1. hey i have been searching the net for 2 days now for a solution to my problem and i started reading some stuff on this board, u sound intelligent so ill give u a bash and see if u can help me!!

    i got a usb 2.0 external hdd case and have put in a 20Gb maxtor drive but windows xp pro on my laptop does not recognise it! sometimes when i change my usb port it blips and says device found only to say it failed to install the windows basic driver?????
    i tryed it on my home pc xp home and it worked fine anyone help i have tried everything bar touching the bios :unch: !

    any help will save me from baldness as i havent stopped pulling hair out for days

    thanks neon :grinthumb
  2. luvhuffer

    luvhuffer TechSpot Paladin Posts: 443

    Hey Neon. I really don't have a specific answer for you, but I have a question. Have you looked in Device manager to make sure the USB controller was working, and or that the enhanced USB controller (for 2.0) was installed? Also do you have any other USB goodies you can plug into the laptop to make sure you don't have a bad USB port? What kind of laptop is it?
  3. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Does it have an external power supply? If not, the USB port may not be giving it enough power.
  4. neon256

    neon256 TS Rookie Topic Starter


    yes the usb ports are working im using other devices in them.
    its powered by a plug!
    any ideas
  5. luxus72

    luxus72 TS Rookie

    check cables!

    I have to tell you that I got some problems with my external hard disk too, which was inside a USB 2.0 enclosure. The disk spontaneously turned off and on and windows xp tried to recognise it every time (ruining every job I did at that moment). I tried everything to no effect, I changed performance settings and drivers, I rearranged the drive-enclosure connection and cables, but nothing seemed to work.
    Happily, after some thinking, I found the solution and now everything is going OK for a long time.
    The problem was due to my USB cable. The one I used was an 1.1 cable. But Hi-speed USB devices need another type of cable, which is identical to 1.1 but has extra shielding. The 1.1 cables are subject to interference. Try to find a 2.0 cable and I am sure many of your problems will vanish automatically...
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...