Windows half loaded

By dyeman ยท 8 replies
Oct 16, 2007
  1. This is going to be a little long winded so I apologize in advance.

    Gotta problem with a Shuttle barebones system I put together about 1.5 years ago. 80G hd, 500mg ram, P4 2.4ghz CPU, Benq DVDRW, Windows XP MCE. Client brought it back when windows was unable to completely boot. I thought it probably had a virus, but could do nothing to get it booted to desktop so I could run antivirus software. I ended up reformatting and reloading Windows XP MCE.

    1. During install, system was looking for SP2 disc. How could it know I had it. I don't believe I had SP2 when I first installed MCE a year and a half ago. When I inserted disk it couldn't find several files. I continued with install anyway.

    2. After installation of Windows I attempted to load MB drivers from disk supplied by manufacturer. This is when I got the error message. "Install Shield engine ikernel.exe could not be launched RPC server is unavailable". So I tried to log on to Internet with a working connection, but system wasn't seeing my DSL modem. When I tried to make a connection I got a memory error. I also notice that Internet Explorer was not installed. So I thought maybe a bad hard drive.

    3. I installed a new hard drive, reloaded windows....system was again looking for sp2 disc, and again couldn't see a couple of files. When I got system booted up I loaded SP2 from disk. Tried to load MB drivers from disc and got same ikernel error as above. Seems like windows only half loaded. There seems to be several missing components including IE. I tried downloading drivers from Shuttle website, updating bios, load optimized defaults. Nothing works I am able to load antivirus and Firefox from disk. Antivirus runs but finds nothing (no surprise),
    This system still doesn't see dsl connection and can't launch firefox.

    Any thought to this ikernel.exe error?
  2. dyeman

    dyeman TS Rookie Topic Starter Posts: 26

    bump any thoughts?
  3. mailpup

    mailpup TS Special Forces Posts: 7,186   +469

    Maybe your installation CD is damaged or dirty. Can you clean it with a soft tissue or other material and maybe some glass cleaner like Windex?
  4. damiruS

    damiruS TS Rookie

    I have the exact same problem. I tried with different dvd's and it's still the same, it cant be the dvd-player maybe? its the only thing i can think of that i haven't tried yet
  5. mailpup

    mailpup TS Special Forces Posts: 7,186   +469

    I don't understand that either. If you booted from the Windows CD you have, you should be able to reformat and perform a clean install of Windows without any references to SP2. Just to be sure, you aren't doing a Windows Repair are you? You are doing a clean install, right? What Windows version? SP1a? Boot order has CD drive first?
  6. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    I think this one is bad memory. I have seen it before but not quite like this - just gets part way into the install and then says it cannot find files. Try swapping the RAM to see what happens?
  7. Spyder_1386

    Spyder_1386 TS Booster Posts: 498

    hey there

    if your problem is just the ikernel.exe file, then try this website. it might help.

    Now, in terms of your reinstalling Windows....if you had installed XP a year and a half ago and later installed SP2 you will need to use an installation disk that INCLUDES SP2 when putting on a fresh copy of XP, ASSUMING YOU ARE NOT FORMATTING YOUR COMPUTER.

    If, however, you ARE infact formatting your hard disk, then the installation cd WITHOUT SP2 should suffice.

    Spyder_1386 :)
  8. dyeman

    dyeman TS Rookie Topic Starter Posts: 26

    Windows half installed

    Thank you all
    I was able to boot from the Windows Media Center CD, reformat and do a "clean install". During this new install set up was asking for SP2, which I have on disc but it did not find all the files. (Still not sure how setup knew to look for SP2 on a fresh install.) When I finished install without missing files I installed SP2 from disc.

    But still everything is not being loaded ie Internet Explorer, disk defragmenter, audio and video drivers, etc. When I tried to load motherboard drivers from manufacturers disk is when I got the ikernel.exe error and right after that a "RPC server is unavailable" error.

    I even downloaded drivers from Shuttle website on a good machine and copied them to machine I am having problems and still got the same error.
    So even though I can boot up windows, I can't log online with my dsl connection to try to get updates, nor can I load my video and audio drivers.

    Didn't really try loading anything else except firefox and AVG which seemed to load okay and AVG will run the scan, but I can't get online to try firefox
    I will try swapping ram and making sure ikernel.exe isn't already running, and if there is no solution there I'll try a different version of Windows OS.
    Thanks again I'll let you know how I make out.

  9. damiruS

    damiruS TS Rookie


    I finally fixed it!
    I tried 2 different new approaches and i guess one of them worked. First of, when i formatted the hard drive before the install i did a full format, not the fast one. And the second thing i did differently was to use another dvd-player, an older and slower one. So if you can, try those things and see if it works
    good luck
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...