Windows not recognizing my USB Storage devices

By roc_pride ยท 5 replies
Feb 26, 2007
  1. Hi Guys, i have a quick question regarding USB storage devices.
    i'm running Windows XP Sp2

    when i plug in my flash drive, iPod or card reader (with a sony memory stick in it) to my usb ports , Windows detects them and the "safely remove hardware" icon shows up in the bottom right toolbar. however, i cant access my USB devices from My Computer, the drives don't show up.

    i read on some other post that you have to manually go into Control Panel->Administriative Tools ->Computer Management, to assign a specific drive to the device. However, after i tried that, the devices still dont show up in My Computer.

    I'm not sure how to fix this, any help is welcome!
    all my other USB devices (such as my keyboard and mouse and printer) work fine
  2. cartera

    cartera TS Evangelist Posts: 365   +113

    This may seem obvious and i don't mean to be patronizing but have you tried a different USB port? I have never heard of this problem. Also when you plug in your Ipod does it appear on iTunes? Also does it not prompt you when you plug in your devices open, run, view pictures etc.? Have you disabled that, if so enable it.
  3. roc_pride

    roc_pride TS Rookie Topic Starter

    the prompt window with options "open, run, view pictures" etc, does NOT come up when i put in my usb storage devices.

    also, i tried putting it in different usb ports and the same problem still occurs
  4. cartera

    cartera TS Evangelist Posts: 365   +113

    All i can think of trying is to stick the device into a USB slot which you know the root for. Im not sure what the root will be f:/ maybe, your main hard drive is ussually C:/. With this go on to the run command and type in run f:/, I don't understand why your computer would be doing this. Are you the administrator because if not your admin may have disabled the use of the USB ports. I am struggling to help you on this one for i am running vista. Make sure you have no security set to your USB hubs.
  5. roc_pride

    roc_pride TS Rookie Topic Starter

    i think i found where the problem is

    when i click on the "device properties" of my USB mass storage devices, it shows that all the "location" of the devices are at location 0 which is exactly the same as my printer. so i guess windows is not recognizing the devices cuz they think it's the same device as my printer?

    i dont know how to go about solving this but i'm pretty sure this is where the problem is

    maybe i should try uninstalling the drivers?
  6. cartera

    cartera TS Evangelist Posts: 365   +113

    Are you sure that the USB ports are plugged in properly, internally?(inside the computer) Try re-installing drivers and have you got anything running of the USB ports on your PC?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...