Windows Vista will not delete file, says access is denied.

By pyromaster114 ยท 6 replies
Nov 27, 2007
  1. Okay, so my father has used some sort of backup software by Acronis to manage to copy the D partition from his HP tablet to his new IBM tablet. This wouldn't be unusual, if it hadn't been for that the D partition on the HP is a restore partition used for restoring factory defaults.
    This somehow invisible but takes up space partition now resides INSIDE the C partition on the new IBM, taking up about 6 or 7 GB.
    It resides in the folder C:\Users\Tom\Documents\Drive(D)\
    I can't delete it. I've tried everything. It shouldn't be there, it's un-needed, and when you try and delete it, it goes "Access Denied, you need permission to access System Volume Information"
    Now I tried deleting it with the command line running as administrator.
    I even tried deleting it through safemode.
    Nothing worked.

    Anyone got an idea how to rip it out or something? It's getting really annoying.
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    God bless the userfriendliness of Windows :D

    Anyway, SVI is a very special folder and Windows is stupid enough not to realise that the one you are trying to delete is not the real thing.

    Take ownership of that folder so that you have full access to it and all objets under it. After that it should be deletable.
  3. pyromaster114

    pyromaster114 TS Guru Topic Starter Posts: 246

    Well, I've made sure that he has ownership of the file, but it still won't delete it.
    It appears to be zero KB now though... so I'm assuming it's some strange bug that it thinks something's there but it's not.
    I can rename the file 0.o... but not delete it...
    I'm beginning to think that maybe I should just have reformatted the disk before he started transferring crud over... Now I'll never get to the bottom of this... oh well his hard disk drive not mine...

    In any case, it's saying I have to get permission to delete "system volume information"
    but there's no folders in that folder at all... especially not one named "System Volume Information..."
    I hate Windows' file system... I guess I'll try and use Admin CMD to take ownership of the file again... see if that works...
  4. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    System Volume Information should be in the root directory, ie. C:\.

    Sounds like you should run chkdsk on that drive.

    It's also possible to mount partitions in NTFS directories, but that's quite unlikely to happen like that. Anyway, you could check from Disk Management (in Administrative Tools -> Computer Management) if that's the case.

    Or maybe it's a symbolic link pointing to a wrong place... in which case you'll need third party utilities to delete it.

    Anyway, the safest bet would be formatting :p
  5. misterazvan

    misterazvan TS Rookie

    try the chkdsk
  6. pyromaster114

    pyromaster114 TS Guru Topic Starter Posts: 246

    Yeah, but my father says that he doesn't want his computer formatted... He'll probably just get fed up with it and tell me okay fine do it, but for now I have to try...
  7. pyromaster114

    pyromaster114 TS Guru Topic Starter Posts: 246

    Can I by any chance use the Recovery Console on the Windows Vista install DVD to delete the file?
    Someone recommended that I try that, but I can't seem to get to the directory in the recovery console.

    Do I need to mount the partition? It says "mount" is not a valid command, so I don't understand what I'm supposed to do really...
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...