Windows XP Home Edition ACCESS IS DENIED!

By noob0 ยท 14 replies
Jan 1, 2004
  1. I always get that ACCESS is denied message! Not when I'm deleting or moving files, but when I'm trying to install files.

    Like when I try to install a printer driver, it says Access is denied.
    Also when I try to install programs such as Norton Personal Firewall, the same message comes up.

    Most of the messages state that I should log in as Administrator first, and then install it. Problem is, I am the computer administrator.

    Please, any help \ comments will be much appreciated.
    I've looked through almost all the archives relating to this problem, but can't really find a solution to my problem.

    My OS is Windows XP Home Edition.

    Need help badly!
  2. SubKamran

    SubKamran TS Rookie Posts: 166

    I got this from a Google:

    This is possible, I checked :)
  3. SubKamran

    SubKamran TS Rookie Posts: 166

    Do you have any Norton software? When did this start happening? (after installing a software)
  4. noob0

    noob0 TS Rookie Topic Starter

    I tried what you posted, but it doesn't seem to have worked.
    I'm not sure when it exactly started, since I only just noticed it when I first tried to install my printer driver. I don't have Norton installed, because of this problem.
  5. atpat

    atpat TS Rookie

    Not sure if you're still having the access denied problem but I had the same thing on one of my work PC's and couldn't find the answer anywhere. I ended up running a repair installation and it corrected the problem.

    Insert your XP home CD and reboot. Boot from the CD and let the installation begin. When prompted to select repair or new installation, select repair.

    Hope this works for you.
  6. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    Thanks for the solution. Hopefully it will help someon in the future, if it hasn't helped noob0.

    :wave: Welcome to TechSpot :wave:
  7. Carbon Kid

    Carbon Kid TS Rookie

    I am having this exact same problem with my ethernet drivers and some of my mobo drivers. If we were to use the recovery console, could you be a little more specific on the solution?
  8. yomom

    yomom TS Rookie

    the secret is in the sauce

    (un)safe-mode harbors a hidden tab in folder and file properties rife with buttons and dialogs for exacting retribution on untouchable files and folder's permission panties. It just saved my buns from that dreaded /system32/config/XXXX file corruption bug that likes to lock out folders and bites me when ever I install GNU software on XP, damn the GIMP! You may have to dig deep to "steal"(ie. read grant yourself) permission from the same system that you birthed, but you must SMACK it like the red-headed step child that XP is.
  9. wellfed

    wellfed TS Rookie

    network file transfers vs. "Access denied"

    I tore my hair out over this problem for days and returned a brand-new HP dv8230 thinking that there were hardware issues. As the poster above says, the issue is indeed the built-in XP security features. Why I've never had this problem on my other 4 XP machines, I don't know....

    The problem: copying by drag and drop to a new computer either via home network or jump drive resulted in all sorts of weird "access denied" messages whenever I tried to edit, move or modify the copied files on the new machine. This, despite the fact that I was logged in as administrator with full privileges, the file attributes were Archive, and nothing was encrypted.

    Solution: reboot in safe mode (not necessary with XP Pro, but this was the home edition), using Windows Explorer- go to the folder you just copied. Right-click. Select "properties" then the "Security" tab. Click on your account name and ensure that all the "allow" checkboxes are checked. Click the "apply" button.

    The first time I tried this from the root of the drive, expecting the permissions to trickle down to the subfolders. They didn't. I had to explicitly do this inside the folders I had just copied over the network for this to work.

    Reboot in normal mode and you should be off to the races. After the headaches this has caused me this week, I'm now doing cartwheels....
  10. axiom

    axiom TS Rookie


    I am not tackie but the simple solution was to boot the PC in safe mode
    Remove all files and folder from

    Reboot in normal mode and install the printer.

    I did lot of things before doing this. I am not sure that it is combination of things or not but it did work for me

    Warning: by doing this you may loose any previously installed printer

    Bye Now
  11. wongton

    wongton TS Rookie

    hey subkamran... i tried what u did by doing all the regedt32 stuff... however my computer did not have the option ?RESET PERMISSIONS ON ALL CHILD OBJECTS AND ENABLE PROPAGATION OF INHERITABLE PERMISSIONS and i just went through without the step... now my computer is really messed up... and nothing will open... also regedt32 now can not be run as there is no folder or something .. help!!!!
  12. HowdyHo

    HowdyHo TS Rookie

    Might Help?

    After a Chkdsk scan completely messed up my system and searching.

    CHKDSK utility incorrectly identifies and deletes in-use security descriptors

    A disk check has been scheduled.
    Windows will now check the disk.
    Cleaning up minor inconsistencies on the drive.
    The security data stream entry at offset 0x1bfff0 with length 0x80010033
    crosses the page boundary.
    The security data stream entry at offset 0x4bfff0 with length 0x80010033
    crosses the page boundary.
    Repairing the security file record segment.
    Deleting an index entry with Id 4971 from index $SII of file 9.
    Deleting an index entry with Id 9614 from index $SII of file 9.
    Deleting an index entry with Id 9614 from index $SDH of file 9.
    Deleting an index entry with Id 4971 from index $SDH of file 9.
    Replacing invalid security id with default security id for file 97.
    Replacing invalid security id with default security id for file 1890.
    Replacing invalid security id with default security id for file 1991.

    It would seem I finally fixed it.

    My First Port of call was Dial a Fix

    Dial-a-fix is an advanced utility for 32-bit versions of Microsoft Windows written by DjLizard in Borland Delphi 7 that repairs various Windows problems, such as:
    Windows Update errors and problems with Automatic Updates
    SSL, HTTPS, and Cryptography service (signing/verification) issues
    COM/ActiveX object errors and missing registry entries
    and more.

    I tried the repair permissions it fixed some and got me back into my account.

    Now what lead me to the fix was a wonderful program called Filemon.

    FileMon monitors and displays file system activity on a system in real-time.

    That told me exactly what the problem was. Which I already new was the wiped/reset security ids.
    But then I search for the files it was having problems with and it brought up:

    Systems that have changed the default Access Control List permissions on the %windir%\registration directory may experience various problems after you install the Microsoft Security Bulletin MS05-051 for COM+ and MS DTC

    In short You got Permission issues in Windows XP Home Like I did If you can get into Windows XP Home in safe mode you CAN fix them. After spending most of the week trying to fix it and then finally doing it I had to share.
  13. computerexpert1

    computerexpert1 TS Rookie

    about the administrative accounts on Windows XP Pro and Home and all service packs. There is a hidden administrator account that has master privleges to all. to access this account: 1. Be at the welcome screen, 2. press CTRL+ALT+DELETE twice, 3. type administrator in the username box, and leave the password blank, it should log you on, if it doesn't and says the account is disabled, log back on to your account and follow these steps:
    a. start>run and type CMD
    b. type net user administrator active:yes
    (this turns on the account, even though it is on, it is not visible in the user account control panel, so to set your password will be a little different. follow steps aa - bb to set the password, otherwise you may now follow steps 1-3 above.

    aa. start>run and type cmd
    bb. type net user administrator password here
    (be sure the password contains no spaces- this will have set the password, you may now follow steps 1-3 above, except: type your password in the password box)

    Helping Everyone,

    Patrick D., Chairman/Technology Director
    Atomic Programming Incorporated

    chairman email:
    Support staff:
    company email: or

    Providing Technical Support, our own software and games, other companies software and games, hardware, office tools.

  14. daveposh

    daveposh TS Rookie

    Thanks to the posts by wellfed and computerexpert1, I was able to recover 7 GB of classwork for my son. Thanks guys!
  15. diondemand

    diondemand TS Rookie

    access denied

    i had a virus on 1 pc called maximus, xp pro shut down wont reboot to welcome screen where i need to access my admin account. so. i used another hard drive with xp home to boot up tried files and settings transfer, copied some files and folders but access still denied to opening them. seems like they are not lost but i cant get to welcome screen to log in with my password to access them. anyone?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...