1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Windows XP Home - No boot device?. (help!)

By DeanoTIK ยท 12 replies
Aug 31, 2005
  1. Hi all, i'd appreciate some help with a BIG problem with my new computer:

    the pc in question is a Compaq Presario SR1280UK (Brand spanking new - got it december last year), here's a website with the specs: http://www.recommendedbuys.co.uk/computers/computers-workstations/compaq-presario-sr1280uk.htm

    (a pretty difficult pc to find on google..)

    its been running well for ages, but anyway's, here's my problem:

    One night, i decided to leave my pc on while i slept, to do a dskchk (aka scandisk), i awoke the next day to a blank screen with these exact words:

    "Reboot and select proper boot device, or insert boot media in selected boot device and press any key"

    (nothing else on screen, just that ^^)

    Now, ive trailed through BIOS, the hard drive is selected, (even loaded setup defaults - although it was already at that anyway) so im totally, utterly stuck, ive rang compaq, they basically said i need a set of recovery disks (i was sposed to make my own - although i wasn't told) problem is, i have no way to pay them (they wont even accept postal orders or cheques!, thats crazy).

    i dont have any disks with the computer (OEM version of windows) only a microsoft works CD, lol, everything is basically on the hard disk (also has a "recovery" partition i think, basically, holding f10 at startup makes the pc wipe the hard drive clean, and set it back to factory, tried it, doesn't work, neither does safe mode, nothing, can only enter BIOS)

    im currently on a older machine (also XP home - but got it 2nd hand without the cd) any idea's guys?, i seriously need to get the new pc going asap, ive managed to buy a cd off some guy called "buttsaver", basically its a windows 98 startup disk, im not familar with this kind of stuff, so could i make use of it?, if so, how? and if not - could someone recommend ANY sites, downloads, anything at all?, im really stuck here.

    I really do appreciate any help, thanks guys.
  2. urbandragon

    urbandragon TS Rookie Posts: 231

    there is only 2 ways to reinstall the o/s on a hard drive.

    using a windows xp cd or using the recovery software that came on that hidden partition. of course you could have used an image.

    what kind of error messages do you receive when they system boots?
  3. DeanoTIK

    DeanoTIK TS Rookie Topic Starter

    From turning the pc on, i get a blank screen, showing the cpu type, ram, etc (normal start screen) next screen says "COMPAQ" in big letters, at the bottom saying (guessing here):

    ESC: boot menu(tried it, start hard drive first, no luck) F1: setup (bios) f10: Recovery.

    none of them menu's work, only bios, safe mode doesn't either (ive tried it on this pc before - f8 at the compaq screen) nothing happens, i can only enter bio's and thats it.

    after that screen, i get this error:

    "Reboot and select proper boot device, or insert boot media in selected boot device and press any key"

    is there any way i can access that hidden recovery partition? (when the pc was working, it displayed under "my computer" 2 hard drives, one, quite small, which is used for recovery, other, my actual hard drive) using the windows 98 cd i have?, i can get a dos command prompt with it at startup, im just not familiar with commands, or...this kind of stuff in general, some help would really be nice.

    thanks again :).
  4. urbandragon

    urbandragon TS Rookie Posts: 231

    when you go into bios is your hard drive listed at all and if so as the primary master, is it set to the first boot device?
  5. patio

    patio TS Guru Posts: 482

    Contact Compaq and have them ship you the recovery discs...

    patio. :cool:
  6. DeanoTIK

    DeanoTIK TS Rookie Topic Starter


    Yea, the BIOS is fine when it comes to the hard drive (cd drive selected first, hard drive second) thats set as default, worked fine like that before, so it shouldn't be that. (even starting from the hard drive first still causes the same error)
  7. mr.smit

    mr.smit TS Rookie

    I had the same problems, the problem with my computer was the HD

    The jumper of the HD was set on CS (cable select), It should be on Single (or master if there isn't a single option), try that and it solved the problem here

    Let me know if this helped you with your problem
  8. DeanoTIK

    DeanoTIK TS Rookie Topic Starter

    any chance on giving us more info on that?, is it on BIOS?.

    thanks again guys.
  9. patio

    patio TS Guru Posts: 482

    The jumpers are on the front of the HDD next to where the power plug is located...for the proper settings if the drive is not labeled clearly check the HDD manuf. website.

    patio. :cool:
  10. mr.smit

    mr.smit TS Rookie


    The picture above is a view from the harddisk (not every harddisk is the same), it tells you how to put your jumpers.

    On the picture you see the pins.
    on the first row, you see 1 pin, that one is just on there for fun or something.
    The 2nd row, is for DS(Master): only 1 drive in PC, or the drive that you want to boot up from.
    The 3rd row, is CS Enabled: Cable select, the computer desides wich harddisk is master and wich one is slave
    The 4th is cap limit: windows cannot run on harddisks that are to big, like 300gb, so putting jumper on cap limit (capacity limit) makes it smaller for windows to use it.
    The 5th row has no use, or i don't know what it does, either of that 2.

    If you look good, it says "No Jumper = DS(Slave) above, slave is simply the 2nd harddisk in your PC, it needs another harddisk with jumper setting on Master to function


    This picture is a view from the back or front, just how you want to see it, the most right 4 pins are for the power to the harddisk, the most left pins are for the connection to your PC, and the middle pins are for the jumper settings, if you take a good look at it you can see my jumper is on the far left.
    On the picture above you can see that I put the jumper on the far left (i took the upper picture when i twisted my camera 45 degrees), it says DS(master)

    I hope this explains a little bit more, if you can't figure it out, ill hear it ;)
  11. mr.smit

    mr.smit TS Rookie

    Ill be checking back tomorrow, im going to bed now, try following my previous post and i hope your problem will be solved

    good luck mate
  12. DeanoTIK

    DeanoTIK TS Rookie Topic Starter

    Thanks Mr.Smit, although i doubt it is that ( as ive not touched the inside of the pc since it was brought) i have taken a look at it though, and i know exactly what you mean (slave/master, etc) but yea - my harddisk doesn't contain any info on where the jumper should be, so ive left it.

    now, like your hard drive, i noticed that you also have the 4 pins on the right(for power supply i think) i noticed my hard drive never had anything plugged into there, only 1 red chord/wire thing, which goes straight to the motherboard from the hard disk, it also has another thing plugged in which...basically says "P5" on the plug.

    i dont recall the hard drive ever having something plugged into the "power supply" port, is there any way i can find out?

    btw, my hard disk is a Maxtor maxline plus II 250gb SATA/150 HDD (god knows what SATA/150hdd means)


    found this:


    thats my hard disk, searching for info about the power supply, thanks alot for the help :).

    edit of edit:

    nm, lol, found this:
    "As an SATA drive, the MaxLine II includes a newer 15-pin power connector that supports hot-swap functionality. It also, however, includes the legacy 4-pin molex power connector that assemblers have all come to love and hate. Either may be used to power the drive."

    lol, i was secretly hoping that was the problem (power cable just...slipped out :p ) would've been simple to fix, but nope, its obviously an error on the hard disk.

    Im going to try my luck with PC world (shop i brought it off) tomorrow, and plead with them to order the recovery disks (its highly unlikely that they will, but i gotta try) if not, there's one guy i know who claimed that he has a friend who works for compaq, i really need to get the new pc up and running asap, as god knows how long this old one will last (i made a thread on this site about it, you can find it here: https://www.techspot.com/vb/topic32484.html just my luck eh?)

    i'll keep you guys informed on what happens ;), keep the advice coming though, its very much appreciated!.
  13. monica

    monica TS Rookie

    Pxe Mof Exiting Intel Pxe Rom

    I need help my home computer has been down for 2mth and I can't seem to fix it. I try to reset my bios and made it worst. I have seen many different message *client mac addr:00 11 09 84 35 a5 guide :00000000-0000-0000-0000-0000000000000 dhcp_ __/ \
    boot failure reboot & select proper boot device. I have a laptop to help me find info online at the same time work on it but still no luck...I don't have much hope at this point but if you can help that would be great.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...