Windows XP Setup / GRUB Problem, PLS HELP!!

By revelin333 ยท 4 replies
Feb 28, 2007
  1. I'm having a problem with windows setup, when I power up, I get the "Press any key to boot from cd", which I do, then I get the "Windows setup is detecting your system's hardware ", then, instead of the blue loading screen, it just goes black.

    I can hear the drive working, but nothing happens. I have the Corsair RAM with the 'ram access' lights that light up when the ram is being accessed, and they don't change, thereby telling me that there is no memory activity.

    Windows and Linux boot fine however, when there is no CD in the drive, and the cd-rom drive works fine as well, when used after the OSes boot. It even boots with my Linux setup disc, just not with the Windows disc. I have tried updating the BIOS to the latest, with no result. The correct boot device priority is also set (cdrom - harddrive - removable) in that order.

    My system specs are:

    ASUS A8N-SLI Deluxe MB
    AMD Athlon 64 +1800 1.8GHz
    ASUS E616P3 DVD-ROM (Primary)
    ASUS 1608P DVD-RW (Secondary)

    Win XP Home SP2/ Fedora 6 dual OS w/ GRUB bootloader

    Fedora occupies hda1 and hda2 partitions
    Windows occupied hda3 and hda4 partitions

    GRUB is installed on the MBR, as opposed to the First sector of the Boot partition.

    Any help greatly appreciated.
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Test the CD (try booting up in another computer).

    Try using the other DVD drive instead.

    Test your RAM with memtest86(+).

    Did you supply SATA drivers to Windows using a floppy? Try doing that or try doing it with newer drivers or try not doing that.

    Try the install with a minimal set of hardware connected.

    Play around with BIOS plug and play, APIC, ACPI settings. Disable unused devices.
  3. revelin333

    revelin333 TS Rookie Topic Starter

    CD works fine elsewhere

    Both DVD drives same result, just cleaned them too. Work fine with other CDs, even windows setup cd, but only by {run setup->restart}

    RAM seems to test fine, it is Corsair, not a value brand

    HDD is IDE, not SATA, would the SATA drivers still apply?

    BIOS was just updated, however with the same results. On a diffrent note - ASUS Update wont let me 'downgrade' the bios, I read elsewhere that I needed to find a previous version of AU, cuz the most recent apparently gives everyone that problem... Im having a little trouble locating a retro version however, esp. cuz the ASUS site has been down for a day or so. But I tried messing with various settings, nothing yet.

    I will try disconnecting the extra hardware.

    Thank you very much for the assistance.
  4. revelin333

    revelin333 TS Rookie Topic Starter

    The memory test results are as follows:

    On the standard tests there were only two errors out of 60 passes, they were both LRAND

    On the advanced tests, there were some ERAND errors, does that imply that the memory is bad, or are a few errors standard for any RAM?

    Thanks again.
  5. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    There should be no RAM errors, ever.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...