WinMgmt wirelesslan USB adapter error

By HackFo
Dec 23, 2007
  1. Ok, for some time ago i bought a 802.11g Wireless LAN USB adapter to access the wireless network in the house, with the adapter it came a zdwlan configuration tool, which i happily installed knowing how troublesome the windows wlan tool can be. Thats when this problem started coming.

    after i had installed the zdwlan tool, it all worked out, but when i started my computer the next day it just froze on the welcome screen. since i have a program called Style Xp who modifies welcome and boot screens, i thought that style xp might be the sinner, so i went in safe mode and uninstalled the app.

    but to no use the problem still appeared. now i do not remember exactly but at some point i removed the wlan usb adapter from my usb port, and it worked!!

    and heres the tricky one, after the pc was running i tried to insert the usb adapter, and the pc froze once more, responding to nothing except pushing the restart button. next i checked the log, exact on the time my pc froze it said:

    WinMgmt kan ikke initialisere kjernedelene. Dette kan være på grunn av en feil installert versjon av WinMgmt, mislykket oppgradering av repositoriet for WinMgmt, for lite diskplass eller for lite minne.

    Hvis du vil ha mer informasjon, se Hjelp og støtte på (used to be an url here but i aren't allowed to post links yet)

    now this is Norwegian for: WinMgmt cannot initialize the core parts, or something, later is says: this might be because of too little memory or disk space. now i can assure you this is not the problem, i got 1 gb free memory at all times, and at the moment 300 gb free space at my main disk, which windows is installed on, none of my other disks are full either.

    and while i was looking at the log, i tried the usb adapter once more, and to my extreme surprise it worked it connected to the network and it didnt freeze!!

    i turned off my pc and tried like 15 more times with different conditions each time. i found out that as long as i had the adapter disconnected when the pc started, and an application window open when i inserted the adapter again, it would work.

    but sometimes i forget to pull the adapter out and then i have to restart my pc and do it all over. i looked for solutions on the internet for about two weeks but i haven't found any solution yet.

    any help will be appreciated!
    in advance, thanks.

  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Uninstall the zdwlan tool and the wireless adapter drivers.

    Download the latest drivers for your adapter from the internet. Do not install the wireless tool.
  3. HackFo

    HackFo TS Rookie Topic Starter

    solved, for now

    didnt work, it still froze on the welcome screen. But i have ordered a wireless lan card instead, hopefully that will work
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...