Wireless Internet Sharing (ad hoc) problems

Not open for further replies.
My network:
  • Router (connected to dsl modem)
    • Shared computer (Wired to: Router)
    • Personal Computer (Wired to: Router)
      • Portable computer (Wireless to: Personal Computer)

My goal:
Connecting the portable computer to the rest of the network and internet.

My settings:
Standard ad hoc (peer to peer) connection.
No encryption yet.
Wired and Wireless connections bridged on "host" computer.

My problem:

Both computers says: "Connected to SSID name"
The laptop gets ip from dhcp but nothing else.

What i've tried:

Reinstalling drivers.
Using static ip.

Oh and, cable works perfectly.

At this point both computers says "Connected" and i get ip for dhcp.
But i can't ping anyone or anything.

Please help me. :confused:


Posts: 2,218   +0
check for firewalls on both systems. If you can't ping its very likely that the system(s) may be ignoring the ping request due to firewall settings.
No firewalls

I double checked.. as i did before i made this post.
There's no firewalls on.
And if they were on they wouldn't work cause they're set to allow all.

It's not just the ping. It's everything except dhcp.
It's just like i'm not connected, only i'm getting ip from dhcp.

El Presidente

Posts: 40   +0
I have the same network type setup except that I don't have a network bridge on the desktop computer. I just have two seperate connections and it seems to work just fine.
Xp Ics Bridge Ad-hoc - Why Not?

I have a very similar problem. I can’t seem to get ICS to work through a network bridge to a wireless ad-hoc network. I’ve tried the following:

1. Host computer has dial-up internet connection, and a wired NIC. I shared the internet dial-up over the wired NIC, which is connected to a hub, sharing connection to multiple other PCs via wired network. All works great. On one of the clients, I also installed a wireless NIC. I setup the wireless NIC to run in ad-hoc mode, and then I bridged the wired and wireless connections, attempting to join the networks, and get the host computer to assign IPs additionally to computers connected via the ad-hoc wireless connection. So I have a wireless NIC in my laptop, and it connects to the ad-hoc network with excellent signal. I even get a valid IP assigned from the DHCP, and default gateway of All looks good, however, as soon as I try to ping, connect to another computer, or get on the internet, no such luck.
2. OK, so this time, I tried putting the wireless NIC in the host computer, rather than one of the client computers. So the host now has a dial-up internet connection, a wired NIC, and a wireless NIC. I bridge the wired and wireless NIC, and then I share the dial-up connection, (which Microsoft says shares the connection to the bridge). The client computers connected through the hub to the wired NIC on the host work beautifully, they get an IP, they get on the internet, life is wonderful. However. I have the same problem via the ad-hoc network as in scenario #1. I connect to the wireless network with good signal, I even supposedly get a valid 192.168.0.x IP address assigned by the DHCP server, and a default gateway of, but nothing works beyond that. No pinging, no connecting to other computers, no internet.
3. Just for the heck of it, I took off the bridge, so I still have the host computer with dial-up, wired NIC, and wireless NIC, but no bridge. So I again share the dial-up connection, but with no bridge, I have to select which network device I want to share the connection to. So I pick the wireless NIC, and guess what, IT WORKS. I get an IP, the internet, and now I’m getting frustrated. Because now I no longer have internet connection on my wired computers.

Ok, so is there some reason why you cannot bridge a Windows XP ICS network and a wireless ad-hoc network using a Windows XP software bridge? Because that’s sure what my testing seems to indicate.

Darn, I guess I’m just going to have to go buy an access point, but I would really like to know what the deal is here.


With much happiness, I am glad to report a solution I found. Follow the instructions in this article:

(I guess I cannot post URLs as a newbie, but feel free to email me for it.)

I’ve included most of the contents of the article that pertain to the problem in this thread below:

“If the bridge appears to be made but doesn't actually pass network traffic, it could be that your wireless NIC doesn't support promiscuous mode, even though, when Windows XP queries the card, it reports that it does.”

Solution from the article:
You need to set the wireless adapter to ForceCompatibilityMode. First, open a command window:
1. Click Start, click Run, type cmd, and then click OK.
2. In the command window, type netsh bridge show
3. Note the number assigned to the wireless adapter and type netsh bridge set a 1 e where you substitute the number displayed in the previous step for the number 1 in this step.
4. To double check the wireless card is correctly set with Force Compatibility Mode enabled, type the netsh bridge show a command again.

Hope this helps. It works for me. One issue someone noted with this solution however, is that they complained of problems when multiple computers attempted to connected via the ad-hoc network. The complaint was that all of the computers on the ad-hoc network were getting assigned the same IP. They were using a wired router rather than windows XP ICS for the DHCP however. I have not had a chance to test this out myself, but if I do, I will post my findings.
Toss the bridge...

My humble system is quite similar except there is one desktop (wired), 3 notebook computers connected to wirelesss router. All I did to make everyone agree and share and get internet was installed the NWLink IPX/SPX/NetBIOS Compatable Transport Protocol on all computers. Router takes care of everything. It is almost as easy if you hunt down NetBEUI Protocol as it is non-routable and keeps your data off the internet, but available to all computers on the house-side of the router. NetBEUI does not work with Windows X-64 and probably not Vista.
Not open for further replies.