Wireless Network problem

By Kevin16 ยท 30 replies
May 30, 2005
  1. Hey

    I have a wireless network running on a DSL line. The router is hooked up to my main PC and I have a laptops which use the internet through the router.

    The problem is whenever I turn on my laptop, the DHCP cannot assign an IP to access the network. I am using dynamic IP, although I don't know if I should use PPPoE.

    Any help will be appreciated. Thanks.

  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    It doesn't matter what you use for your WAN port - the router has to assign LAN IP addresses through DHCP even if there is no internet connection at all.

    Does the laptop connect if you give it an IP manually?
  3. Kevin16

    Kevin16 TS Rookie Topic Starter Posts: 92

    No it doesn't. It only works if I reset my router every single time I turn my laptop on.
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Does your main PC get an IP address automatically? What is the address it gets?
    Do you connect your laptop wirelessly or through a network cable?
  5. Kevin16

    Kevin16 TS Rookie Topic Starter Posts: 92

    Yes, my PC gets an IP automatically. My laptop connects wirelessly to the router.

    Acually, my laptop connection does not work after a long period of time and I would have to reset my router because it says I have an "invalid IP address." I have tried using the repair option but it fails to renew the IP.

    BTW: How do I know what IP to use if I gave it manually?
  6. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Something similar to what your other computer gets. The safest bet would be just to increase the last digit by one e.g. if the desktop gets you would assign the lappy All the other addresses (netmask, gateway, DNS) have to be the same.

    You should try the laptop with a wired connection to test if the problem is with the wireless.
  7. Kevin16

    Kevin16 TS Rookie Topic Starter Posts: 92

    Thanks for the tip, but this crappy laptop does not even have an RJ-45 jack.

    But yeah my router address is and the DHCP is supposed to try all IP addresses ranging from to
  8. aidsministrator

    aidsministrator TS Rookie Posts: 26

    Ok. I am not here to give my solution yet but i'm here to ask you some questions first.

    1. Are you using a wireless router (connected to your DSL modem)?? or a single-port access point (connected to your router then the DSL modem)???

    2. When you turn on your laptop, does it 'tell' you that the laptop has found any network/internet active connection signal from the wireless device?

    3. So you're saying like, you can connect to the Internet using your laptop just if you reset the router? and then, If you off your laptop and turn it on again, do you still have to reset the router so you can connect to the Internet?
  9. Kevin16

    Kevin16 TS Rookie Topic Starter Posts: 92

    1. I am using a wireless router.

    2. I do "connect" to the router but I do not receive any packets due to an invalid IP.

    3.I'm saying that I can use the Internet but periodically stops receiving packets for some reason (IP changed maybe) until i reset my router. After i reset it, the DHCP reassigns the LAN IP (working) again. It's not just when I turn on the laptop, but sometimes in the middle of something also.
  10. aidsministrator

    aidsministrator TS Rookie Posts: 26

    Hmmm.. quite tough.. but you still can try my procedure.

    1. sounds like you're using dynamic ip for your wireless card. no i don't recommend you to use dynamic ip-ing. I had the same problem before where my wireless device (laptop) was unable to 'catch' the wireless router signal. sometime can catch but sometime cannot. This is because I was using dynamic.

    1a) so use static ip for wireless. This is not too important actually but just use static. Enter all correct ip addresses into your wireless network connection setting (in TCP/IP properties). You must enter a correct IP address of your wireless router into the 'Default Gateway' field.

    2) Do you know how to access your wireless router? If yes then change the 'Wireless' settings. Here is my recommendation;

    2a1) SSID: You can use the workgroup name of your network for this one
    b) Channel: 6
    c) Authentication: Open System
    d) WEP: Enabled (yes! try using wep. I used this option before & my internet works!)
    e) WEP Encryption: 128Bit (up to you. I just suggest 128)
    f) WEP Mode: HEX
    g) Key: 12345678901234567890123456 (it's up to you also)

    2a2) Then configure your wireless card using this information. You should have a program that enable you to configure your wireless card. You can find the program in the Start > All Program.

    After you finish configuring. Try surfing the web. Is it working now?

    working or not, you have to restart your laptop. after finish booting up then open the program again & check wether the configuration you configured before is changed or not. If not changed, then ok.

    Oh ya.. always check your signal level.

    I'm not quite sure this can help. but trying is good. I did all this when I have Internet connection problem with my laptop. Now ok. Since I use 'permanent' settings. Not dynamic..
  11. Kevin16

    Kevin16 TS Rookie Topic Starter Posts: 92

    I have done all that and then some. It just seems to "lose" its IP address after a long time.

    BTW: My signal strength is always excellent.
  12. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Change your DHCP lease time to some 10 minutes and see if your disconnections match with that.
  13. Kevin16

    Kevin16 TS Rookie Topic Starter Posts: 92

    The least lease time (no pun intended) is 1 hour. Right now I have it set on a week, but I'll bet that's the problem.
  14. aidsministrator

    aidsministrator TS Rookie Posts: 26

    Yes, that might be the problem. shorter the least time, better it refreshes.

    Nodsu, can you explain what is this 'Least time' you mentioned above and what is it for?

    I do know least time is always in router's setting but still don't know how to use it. Thanks a lot Nodsu
  15. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Lease time is the time an IP address assigned by DHCP belongs to that host.
    If a client doesn't renew its lease the address is put back into the free IP address pool. When a client doesn't succeed in renewing its address, it will give up the IP when the lease expires,

    For some reason Kevin's computer doesn't renew its address. Making the lease time longer is a workaround but not a solution here really.
  16. Kevin16

    Kevin16 TS Rookie Topic Starter Posts: 92

    so can we conclude that my router is broken?

    I have tried other wireless cards on other laptops also. Same problem. I have done quite a bit of configuring, but the problem still remains.
  17. Kevin16

    Kevin16 TS Rookie Topic Starter Posts: 92

    Hey. My router is a D-link DI-624 AirPlus X-treme G. It was supposed to be very good with a lot of features, but it sucks. I have read many reviews on it and customers said it "continually disconnects" and "keeps rebooting." I'm just going to exchange it because I just bought it.

    Well, here are the X-tremely unhappy customers
  18. aidsministrator

    aidsministrator TS Rookie Posts: 26

    Surprise surprise.. I'm using a same router too. yes it sometime lost its connection with the modem but turns fine after 5 minutes after I repair the LAN connection. So far, I quite like D-Link. It's better than Linksys.

    The router works fine with wireless. I don't have any problem yet. By the way, my router is about 4 months old already. Still new.

    Have you check the user's manual? Maybe you have configured some wrong particular settings on your router.

    Check the WLAN LED on your router. Does it light up staticly? (no blinking?) My WLAN doesn't blink.
  19. Kevin16

    Kevin16 TS Rookie Topic Starter Posts: 92

    I DID NOT CONFIGURE IT INCORRECTLY!! I have friends who no nothing of networking, yet their router and internet connection is fine. Are you trying to insult me? See, if I were the only one with this problem, I would probably believe you, but apparently I'm not.

    most routers of this model is buggy, as you can see in the reviews. Some are quite fine though. It's just don't think it is tested enough and most of them are flawed. You did see some good reviews right? Those are the exceptions.
  20. tdeg

    tdeg TS Rookie Posts: 119

    Looks like it might be a dud model.

    I have the 524, it works great. I use a VPN connection over the wireless and it is pretty sensitive to interuptions and I had VPN up for like 6 hours.
  21. tdeg

    tdeg TS Rookie Posts: 119

  22. Kevin16

    Kevin16 TS Rookie Topic Starter Posts: 92

    Yeah. Thanks for the tip, but it doesn't matter now because I have a linksys.

    The new D-link model needs to be tested more. It is too faulty.
  23. Bobcat1132

    Bobcat1132 TS Rookie Posts: 79

    go to run and type the command cmd this will bring up the command menu typing only then typ the command route print just like that this will tell you your gateway, subnet mask and ip address assuming that you have one. do this and let me know what each one is it may be a problem with the router does it have a built in firewall. i know that may cause a problem
  24. Bobcat1132

    Bobcat1132 TS Rookie Posts: 79

    d-lynk has problems thats the wireless i have right now and it gives me trouble some times good luck
  25. StormBringer

    StormBringer TS Maniac Posts: 2,244

    I'll not bother with the dribble the others did, just simple couple of things to try.
    Update the driver for the wireless adapter, update the firmware for the router(even if you bought it yesterday, it prolly sat on a store shelf for six months)
    Try performing a release and renew of the IP while it says it is connected. Start>Run>CMD, then type "ipconfig /release" hit enter and wait for it to bring you to a prompt again, then type "ipconfig /renew" and wait for an error msg, this will give us a bit more of an idea what is going on. There are errors that can narrow it down a bit.

    Also be sure to double check firewalls(yes, some can interfere with getting an IP if configured incorrectly) Could also be encryption causing the problem.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...