Would some generous soul graciously help me w/ Radeon 9800&Direct 3d?

By Tabasco ยท 4 replies
Jun 15, 2004
  1. Hi! My name is Lee, and though I know most of the basics I still don't consider myself very good with computers. My basic problem right now is my BRAND NEW video card i have been anticipating for so long doesn't work. Heres the deal.

    I have a:

    Gateway 1000mhz Athalon
    Windows XP Pro
    384 mb RAM
    VIA Apollo motherboard
    NVIDIA Vanta TNT2 GFX card (which is being replaced with the Radeon 9800 Pro)

    Everything went horribly wrong the first time i tried installing the card...so i decided to reformat my hard drive (needed to be cleaned anyways). Here I am, brand new PC again. Once again, I uninstalled the old NVIDIA drivers. I went on the internet and downloaded the most recent 4-in-1 drivers for my motherboard. I also went out and downloaded direct X 9.0. After that, I unhooked everything form the PC and put the GFX card in. Turned on the computer, inserted ATI's CATALYST software CD (drivers, etc), and did a full installation. Reboot. Now I installed my favorite game, Mechwarrior 4, just to test things out. It started ok, but just as it loaded all of a sudden these really weird and multi-colored triangles appeard in different sections of the screen. The intro movie to the game still played, but these triangles would pop up everywhere and cover stuff up. After the intro, the main menu wouldnt pop up but the background did. still there were triangles. I moved the mouse around and heard noise after passing over certain buttons but still couldnt see them. I tried picking one and the game froze. I exited everything and went to the windows screensavers. Certain screensavers would work, namely anything 2-d I guess, but the ones like 3d pipes and 3d marquee, etc, would cause a lock up. I opened the directX diagnostic tool and went through the testing. DirectDraw's tests worked ok, but when it came to direct 3d acceleration nothing showed up. Even with my old 16mb video card I could see the spinning cube during tests, and also AGP acceleration was supported, but with my new card the cube wouldnt appear and AGP texture acceleration wasnt even AVAILABLE. Here is the error code i got when testing Direct 3d accelleration:

    Failure at step 32 (User verification of Direct3D rendering): HRESULT = 0x00000000 (error code)

    I tested everything else directX related, which all works.

    I also tried one last inspection, ATI's PC-check. This time, all but two tests were passed. The 2 which failed were the following:

    1.*Direct X components are not installed properly*
    Recommendation: Re-install DirectX 8.1 or later.

    2.*Capture Driver INF files are not installed*
    WDM devices INF file not installed.
    WDM devices are not listed in registry.
    WDM devices are not loaded or enumerated by the device manager.
    WDM devices are not registered with DirectShow
    Recommendation: Get the capture drivers and the recommended ATI display driver from the ATI website.

    Well, I did both of those recommendations, and not a SINGLE thing changed. This is the same problem I was runnning into before i reformatted, so i doubt its windows. Ive tried reinstalling drivers, etc, and NOTHING WORKS! HELP ME PLEASE!!!

  2. FeTaLDaMagE

    FeTaLDaMagE TS Rookie Posts: 44

    Sounds like the 9800 has issues with the game, did you see if the game has a patch to deal with some of your problems. Just a stab in the dark here. Second, is windows up to date? Are you using sp1? Third did you goto ATI's web site and download newest drivers? This alone may resolve the game issue.
  3. Tabasco

    Tabasco TS Rookie Topic Starter

    Its not the game...other games having the same problem, as well as other applications (e.g. WINAMP plugins for visualizations with the music dont work...just a black screen with those triangles)

    Forgot to mention, yes, windows is COMPLETELY up to date as of this morning, with SP1.

    And yes, I tried downloading ATI's stuff to no avail...
  4. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    It might be the card heating up in which case you could try to run it with the case open ( or maybe underclocking the core/memory speeds )

    It could also be the card not getting enough power from the PSU. Is the Molex connector properly connected on the card ?

    BTW you are really gonna cripple that card with the system you're using.

    PS. Welcome to TechSpot. Hope you enjoy your stay.:wave:
  5. MrGaribaldi

    MrGaribaldi TechSpot Ambassador Posts: 2,512

    Have you tried the latest drivers from ATI's site?
    (Only asking since you said you loaded the drivers from the cd)

    It seems the most likely culprit especially because of this
    Though after reading your reply, I see that you have downloaded the latest drivers.

    But did you install the drivers before or after you installed DX9.0b? (You're not running a beta/ripped DX9.0c are you?)
    It might help if you try to do that, as that should force the drivers to be registered with D3D...
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...