Xmnt2002 & autochk problem

By surfersaiyan
Jul 1, 2008
  1. hi everyone, just a quick post to say "g'day" and that i hope to be doing as much giving as taking from these forums.

    with regards to the title of my post i recently made a monumental FUBAR when trying to dual boot XP and Backtrack and i ended up with the above messages.

    xmnt2002 program not found
    autochk program not found

    after much tearing out of hair and other things the fix was simple. i found out from here and other places that the problem had been created by Partition Magic (damn you).

    when creating the partition where Backtrack was gonna live, PM had only gone and hidden my windows (ntfs) partition. i could see that running Backtrack from a live CD that all my files and stuff were still there so all was not lost.

    so with scant info garnered from here and there i put 2 and 2 together and realised that i really only needed to 'unhide' and then activate my windows (ntfs) partition. which i did with the Backtrack live CD using QTParted.

    SO... for anyone with the above error messages, this is the simple fix:

    boot backtrack from the live cd.
    open qtparted.
    look at the partitions you have, one will be ntfs and status will be hidden.
    you have to right click on it and uncheck 'hide' on the menu.
    then, this is important, you have to go to the file menu and click on "save & commit" or nothing will happen.
    then, your ntfs partition will go red (which is pretty scary!)
    so at this stage i restarted my pc back into Backtrack for good measure (or to see if i really had stuffed it up beyond all reco!)
    then you have to open qtparted AGAIN and then right click on the ntfs partition again, and go down to something like "make active".
    it will ask you if you want to swap the active partition and you should click 'yes.'
    AGAIN, you should click on "save & commit" and then restart.
    you should then be able to boot windows normally.

    i worked all this out from several sources but worked out that basically the error message is due to using Partition Magic. apparently, when you make a linux partition with PM, BY DEFAULT IT HIDES YOUR WINDOWS NTFS PARTITION. HOW STUPID!! then you have to use something else (of course cant use PM unless you made recovery discs, and who does that?) in order to correct the problems.

    anyhoo.. upshot is, i worked it out and fixed it by myself. which in the grand scheme of things might not seem hugely techie.. but anyone i talk to about this just goes.. "HUH???" so i'm feeling pretty satisfied with myself right now!!

    in the future, i will endeavour to dual boot backtrack & XP.. but for now i just need a sit down!


  2. larryiam

    larryiam TS Rookie Posts: 476

    Hello surersaiyan and welcome to Techspot :wave:

    Please take a moment to read the following threads to make your experience here as enjoyable as possible

    Message for all newcomers

    SNGX1275's 2008 updated Guide to making a good post/thread

    The Techspot FAQ

    Do NOT post your Computer Questions/Problems in this Forum

    If you could take a minute to fill in some of your profile information that would be helpful to all members of the forum.

    Knowing someone's location in the world can be extremely helpful, even if you just put a country.

    Also remember to post any problems or questions that you have in the appropriate forums

    It's good to meet you and I hope you enjoy it here


Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...