XP Pauses during startup and shutdown, Generic Host Process error... help appreciated

By xChuck ยท 8 replies
Jan 28, 2005
  1. This will be long, so please be patient with me.

    Earlier today, I picked up a Belkin 3-Port Firewire PCI card for my pc (model number F5U502). I had booted my PC before going out, and everything was fine. I turned off my PC, powered down the PSU, unplugged everything, and installed the Firewire card. After plugging everything back in, I booted up my PC. Everything was fine up to and including the login screen. However, after I logged in, my computer paused, displaying only my desktop wallpaper, for fifteen to thirty seconds. Once things did start moving, a "Generic Host Process for Win32" was apparently blocked by Windows XP's Data Execution Prevention utility. It asked me if I wanted to send an error report, and I said yes. No new hardware notifications popped up. I tried to install the firewire card manually, but all that did was kill my internet connection. I powered down my system, now noting that there was a delay before it powered off that hadn't been there before. I went through the unplugging and such and removed the offending card. When I booted my computer again, the same pausing occurred, and the same "Generic Host Process for Win32" error appeared. My internet still didn't work. I went through this multiple times, installing and uninstalling drivers for both my Marvell Yukon Ethernet adapter and the Belkin Firewire card. Finally, after installing and removing the Firewire card three or four times (this time it was removed), I managed to update my ethernet drivers and get my internet working (downloaded files on an old crappy computer and used flash drive to move files). However, my startup was still lagging, and my system still waited five seconds before powering off (which it didnt do before). I have run my anti-virus program, I've checked for spyware, I've searched all over this and other forums, I've cleaned my registry, I've uninstalled programs, I've installed startup utilities like bootvis... I've tried everything... I need help.

    Oh, and, after I resigned myself to the fact that windows was going to start slowly, I tried installing that firewire card again, and had no difficulties (after most of the other things I mentioned earlier).

    If anyone can think of a way to get rid of the lag in my startup and shutdown, I would appreciate your help.

  2. hp_compaq_tech

    hp_compaq_tech TS Rookie

  3. xChuck

    xChuck TS Rookie Topic Starter

    Thanks, you gave me some ideas

    Thanks for your help... I'd read the knowledge base articles, but rereading them gave me an idea or two that I want to try out.

    I've taken a few other steps. I tried installing a separate ethernet adapter and disabling the Marvell Yukon, but it only managed "limited to no connectivity," despite XP saying that it was installed properly. I also updated my BIOS (it needed it) but it had no effect.

    As a side note, I'm running both Windows XP Home SP2 and SUSE Linux 9.1 for kicks. It's Windows, of course, that's having problems. SUSE is working like a charm.

    If anyone else has any other suggestions, I'd appreciate them.

    Also, does anyone know the specifics of what Windows' System File Checker really does? Does it replace chaged system files, or just damaged ones? Because if it just repairs damaged files, I'd like to give it a try (unless its a bad idea...).

    Thanks again for your help!
  4. Triton

    Triton TS Enthusiast Posts: 82

  5. xChuck

    xChuck TS Rookie Topic Starter

    ah... much more info now, thanks

    I hadn't known about the Event Log... now I'm finding a bit more information on some of the problems... Thanks! If it would help to post some of the error codes, please let me know.

    EDIT: None of the error codes really helped me find any solution, and I STILL can't figure out why windows is starting so slowly. My next step will be to uninstall any offending devices and then reinstall them. Wish me luck... I'll need it.
  6. xChuck

    xChuck TS Rookie Topic Starter

    okay uninstalling the Firewire PCI card got rid of my slow startup and shutdown. However, something about changes in the PCI items on my mobo (ASUS P5P800) messes with my integrated Marvell Yukon 80001/80003/80010 Gigabit LAN, and I cannot get it to work.
  7. bobby269

    bobby269 TS Rookie

  8. xChuck

    xChuck TS Rookie Topic Starter

    its been awhile since I've been to the forums.

    the problem, it seems, was the driver for an HP network printer that I had installed. Uninstalling and reinstalling the printer with updated drivers got rid of the "Generic Host..." dialogue box. The reason the firewire card didn't work right is because something went wrong when I was installing it. I fried my PCI slots, and since the ethernet runs as an onboard pci device, it wouldnt work.

    I couldn't RMA the board, so I got a replacement.
  9. wright123

    wright123 TS Rookie

    I too kept getting the Data Execution Protection regarding the Generic Host Process for Windows Services . . . message. Very annoying.

    After reading the posts about the HP network printer (which I also own) I executed the HP Software Update tool on my computer and it downloaded an HP patch. Took a few mins to download and install and presto - problem gone. Thanks everyone.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...