1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

XP Pro 'ARC firmware' boot problem while upgrading WinME

By hoggw
Jan 23, 2005
  1. While upgrading From Win ME to XP Pro the following error is displayed during the first system reboot:-

    I have no idea what ARC or HAL is and cannot find any reference to it in the Windows documentation I have. I have found that others have had this error during upgrades but no solutions have been posted as yet.

    Any suggestions on how to get past this would be appreciated.
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    We need some more information before we can help you.

    What are your system specs.

    You can enter you system specs in user profile at the top of the page click on edit profile.

    It would seem that you may need a firmware update for your mobo.

    Please see the following article. http://h18007.www1.hp.com/support/files/alphant/relnotes/as2000note.html

    I`m not saying that this applies to you but it will give you an idea as to what may be required.

    Regards Howard :wave: :wave:
  3. suzumebachi

    suzumebachi TS Rookie

    I'm getting the same error.

    My computer took a gigantic **** the other day. My dad got a virus while surfing for porn (he uses IE, which explains a lot) and went nuts and started deleting files in my system32 folder. Needless to say, this mucked things up big time, and he is no longer allowed to touch my computer.

    Well in my infinite wisdom, I booted off my WinXP Pro CD, went to the recovery console, and did a scandisk. Not thinking at the time that WinXP Pro out of the box has a 137 GB Hard Disk size limit. So of course, my 250 GB drive gets ****ed up major league by the scandisk.

    So, I get my Maxtor CD out, boot to it, and do a low-level (zero write) format. Did a full, 6 hour test scan to make sure things are working, and everything checks out OK. So I partition the drive into 3 segments, each under 137 GB in hopes that the retarded windows installation won't be retarded and screw up on me again.

    The partitions were set up as follows:

    1.) 15,003 MB NTFS
    2.) 120,000 MB NTFS
    3.) 116,000 MB NTFS

    So I run the Windows Setup, and it detects them all ok. I install windows to the 15GB partition, and everything seems fine. Go through all the setup, even up through the first windows boot.

    But, after that, things went to hell again.

    "Windows could not start because of the following ARC firmware boot configuration problem: did not properly generate ARC name for HAL and systempaths.
    Please check windows documentation about ARC configuration options and your hardware reference manual for additional information."

    What the hell, says I.

    I formatted again, repartitioned, reinstalled, and on the first boot tried to install SP2, which fixes the 137GB limit, but when the SP2 installation rebooted after completion, it gave the same error the next time it booted up.

    I'm at a loss. I have no clue what is going on here. I have a feeling it has something to do with the 137 GB limit, but I have no idea how to get around it. The Maxtor CD has a Dynamic Drive Overlay that's supposed to force the OS to read larger drives, but unfortunately the code was written by a gaggle of drunken retarded 8 year old quadraplegics who couldn't tell the difference between a cout and a switch.

    Anyways, here are my system specs if it helps:

    DFI LanParty UT II nF3-250 mobo
    AMD Athlon 64 3200+
    1024 MB DDR RAM
    250 GB Maxtor DiamondMax Plus 9 HDD
    LG 52x32x52 CDRW
    NEC 16x/8x/4x Dual Layer DVDRW/CDRW
    GeForce 2 Pro
    Audigy 2 Platinum

    Help would be GREATLY appreciated. Thanks in advance.
  4. suzumebachi

    suzumebachi TS Rookie

    bump? :(

    i did another low-level format, used windows setup to do a 15 GB partition, installed to it, installed SP2, partitioned the rest of the drive successfully, but it still does this stupid error.

    if i boot to the XP CD, go to the recovery console, and do a fixboot, it works good for one or two reboots, then happens again.

    please, i am begging you. i really need help here. :(
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...