XP pro install laptop no cdrom banana error message

By leon phelps ยท 14 replies
Mar 1, 2005
  1. Hello,

    Trying to install xp pro on a laptop. I have no cdrom and no floppy for the laptop. I do have a laptop to IDE adapter for the hard drive.

    Here is where I am...
    I boot a separate PC with a 98SE boot disk. I fdisk the drive. I then format the drive. I then type in sys c: from the a: prompt. I reboot with the SE boot disk. I then try to copy the i386 folder to the c: drive with "copy *.* c:\i386 " when in the r drive(mscdex makes my cdrom r drive). I then copy until I get to banana file then get kicked out. I have tried to do this with three different XP pro cd's. All look good, all give the same message about error from banana device. I think the error message is from CDrom.

    Any suggestions would be greatly appreciated.
  2. leon phelps

    leon phelps TS Rookie Topic Starter Posts: 23


    Hello again,

    I have since tried some different things with the same result.

    I have now booted to 98SE boot disk. I then fdisk creating one fat32 partition. Size is 6.4 gb. I then rebooted. I then formatted c: /s. I then rebooted without the floppy then got the dos prompt. I then rebooted with the xp pro Cd and the created an i386 directory on the c: drive with mkdir i386. I then tried to copy the i386 folder from the cdrom (r drive) with command copy *.* /e c:\i386. Dos then starts to copy files until it gets to the banana file. Then I get
    Invalid device request reading device BANANA
    Abort, Retry, Ignore, Fail?

    Still floundering here. Any help appreciated.
  3. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Have a look at this post: https://www.techspot.com/vb/topic21314.html

    You should also look for a 20GB Hdisk.

    As to the BANANA, check all connections in that PC. Reseat the CPU, cards and memory.
    You might have an incompatible old CD-rom, or a dirty CD.
  4. leon phelps

    leon phelps TS Rookie Topic Starter Posts: 23

    same result...


    I re-partitioned the hard drive to c: and d:. I then formatted c: /u /s. Then I formatted d:. I then xcopy r:\i386 /e d:. When I get to the banana.DL_ file I get the same message. I have tried three CD-rom (one NESI, one Acer, and one Sony). I also have tried three different Xp-pro Cd's and one Win 2000. It is a slim chance that the copy would kick out on the same file on different CD's and different OS's.

    Any other suggestions are appreciated.
  5. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    That's a weird error, a file is not a device. Apparently a bug in DOS file handling.

    The only banana.* file I see in XP Pro CD is banana.ani, an animated mouse cursor. If you don't need that, you can skip it.
  6. leon phelps

    leon phelps TS Rookie Topic Starter Posts: 23

    Since I am all the way up to the banana file, is there a way for me to start xcopy from there to the end of the alphabet? Of is there a way to do an xcopy minus this one file? I did a regular copy of each letter *.* to the d: drive and it took quite some time. Just looking for a shortcut.

    Thanks as always.
  7. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    You typed: xcopy r:\i386 /e d:
    Should be : xcopy r:\i386 /s /e d:
    where /s = subdirectories
    and /e = empty directories

    You are probably missing some files!
  8. leon phelps

    leon phelps TS Rookie Topic Starter Posts: 23

    Many thanks for all of the help. I will try it now.
  9. leon phelps

    leon phelps TS Rookie Topic Starter Posts: 23

    Same problem here again.

    I gave up and put 98SE back on it. I even broke the KB/TP connector. Should have put it on ebay from the start.

    Thanks for all of the help.
  10. robt

    robt TS Rookie

    What a major pain in the a to answer a simple question. I had the same problem just a few minutes ago, had the same thing happen a couple of months ago, figured out the solution, but couldn't remember what it was, so googled for it, found your thread, suddenly remembered my solution, decided it would be good to tell you, but what a hassle and waste of time to register, wait for email, click the link etc etc.. Probably last time i register to help... Sucks that if there's no registration, the info is so ridden with useless junk, advetisements etc... but who has time...

    Anyways, it sounds like you are using a win98 boot disk that was created with one of the utilities that you can download off the net- the ones that make a boot cd that's great for t/s'ing a system- has generic cd rom drivers, etc etc...

    The bootdisk is probably set up to give the cd drive the name of banana. The programmer probably made the utility before xp was out... XP apparently has a problem copying a file with the same name as a storage device... you can edit config.sys/autoexec.bat and change the word banana to something not likely contained in any of the xp system files..

    Strange enough, my bootdisk gives my cd the name of banana, but i'm installing xp off the had drive, no cd involved, but same problem untl i change the device name.

    Haven't tried it, but if you're given the chance (varies with the system) you should be able to just skip the file, since banana.ani is just an animated curso (if i remember right)

    Robert Isais Trujillo
  11. leon phelps

    leon phelps TS Rookie Topic Starter Posts: 23

    I thought so...


    Thanks. I thoght is was something along those lines. I was unsure where to rename the files, so I just moved on with the laptop.

    The option to skip the file does not help. You either get stuck retrying or aborting.

    Many thanks for the reply.
  12. robt

    robt TS Rookie

    The bootdisk names the cd device "banana" using the config.sys and the autoexec.bat files, so open those two files on the floppy with any text editor, find every instance of the word banana and replace it with something that won't likely be a filename in the xp setup files, i.e. "boot001". There should be one instance of banana in autoexec.bat and one in config.sys if i remember right. Once they're changed, reboot with the floppy, and you should be able to run xp setup with no problems..

  13. leon phelps

    leon phelps TS Rookie Topic Starter Posts: 23

    My Win98SE boot disk does not have either config.sys or autoexec.bat.

    Any suggestions?
  14. robt

    robt TS Rookie

    I don't know how to identify the bootdisk utility that i use to make my bootdisks to see if it's the same as what you use. The filename seems to be different from different sources.. When i double click the exe in windows, though, it comes up with a little dialog box titled, "batch assistance" with the prompt "insert floppy to write". Sound familiar?

    Your results with the banana error are identical to the problem i had.. The files config.sys and autoexec.bat should be on the boot floppy. Do you have windows explorer set up to hide system files? To check open windows explorer, go to tools/folder options, click the view tab, put a dot in "show hidden files and folders and also take the check out for hide extensions for known file types, click apply/ok, and look at the floppy's contents again.

  15. leon phelps

    leon phelps TS Rookie Topic Starter Posts: 23

    I needed to uncheck the box to hide protected OS files.

    Many thanks. I am al ready when I need to do this again.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...