Spread the love! TechSpot Tech Gift Shortlist 2017

XP SP2 crashing at boot

By canesheadcase ยท 7 replies
Oct 23, 2007
  1. hey all, I used the search function here, didn't real help me, did some research and I have some ideas, but some help would be great...

    Ok, I got a virus about a week ago, it was fatal, I backed my data up, and formatted the drive, all is good. I got my XP cd, installed XP, all is well (I'm here aren't I?) and then I realized my version of XP is like... 5 years old. I went to microsoft update, got tons of updates, and the last one I was working on was the "Service Pack Two". When we installed this awhile ago, we had problems, but we had a friend fix it, so I have no idea what we did to fix this problem. Here we go...

    Start XP after SP2 is installed- little bar of loading, etc. then blank black screen...

    Reboot, start in safe-mode (all safe modes networking, command prompt, etc.) I get a huge list of drivers, last one that comes up is "mup.sys"

    So I googled it, found like 82934712342314 other people with the same-ish problem, but the stuff like "chkdsk /r" didn't work, the "un-plug your mouse" approach did nothing, so I'm here.

    Some people pointed out "mup.sys" is not the problem, and someone suggested the BIOS (which sounds familiar), any help would be fantastic, I really did try to do some problem-solving myself, but alas I am empty handed.
  2. onesmartidiot

    onesmartidiot TS Enthusiast Posts: 95

    are you using an sp2 disc?

    reason i ask is because my buddys system spit a ton of errors out when we tried installing windows. turns out unless youre using an sp2 disc, windows wont see pci express. (gives the symptoms you explained) i had to install windows onto it from an old agp computer. but ill see what comes up with that mup.sys code.

    just a thought.
  3. canesheadcase

    canesheadcase TS Rookie Topic Starter Posts: 24

    Nope, I downloaded it from the update site, so it's not the cd.
  4. Cinders

    Cinders TechSpot Chancellor Posts: 872   +12

    We need to two things for sure before we go any further.

    1 We need to know if your hard drive is still perfect. From your Windows install disk you need to run chkdsk. You will boot into your install disk and do a repair of a current installation using the recovery console. At the prompt you will type chkdsk C: /f /r. This will check your C drive for errors and recover any data that it can. If you have errors here it's time for a new hard drive.

    For your reference:

    2 We also need to know that your memory is still perfect. Please go to http://www.memtest.org/#downiso and download and burn to CD or write to floppy/flash drive version 1.70 of Memtest+. Run the program for at least eight complete passes. This will take some time. If you have no errors we will know that your memory is not the problem.
  5. canesheadcase

    canesheadcase TS Rookie Topic Starter Posts: 24

    ah-ha, I did the chkdsk and yep, when it finished it said "found and fixed one or more errors" so I ran it again to be sure, and it came out clean. And I ran the memory test (dang that was long) and it came out clean (it said no errors after several passes).

    SO, what now? And thanks a ton for the help, it really is appreciated.
  6. Cinders

    Cinders TechSpot Chancellor Posts: 872   +12

    Have you tried to boot your computer? This link http://www.cyberiapc.com/forums/index.php?showtopic=5288&st=15 says we did the right thing, but there are suggestions that the problem is hardware related. If your computer will still not boot then you might try to disable mup.sys in the recovery console with "disable Mup.sys"

    "MUP stands for "Multiple UNC Provider" which assists Windows in locating resources
    >when more than one redirector is on a machine such as "Microsoft Client for Microsoft
    >Networks" and the "Novell Client for Novell Netware". When a connection to a server
    >is requested it does not know if the request is to a Novell server or an NT server.
    >It will start looking for the server with the primary protocol on the primary requestor
    >and then continue looking for the server on each protocol bound to each redirector
    >until the server is found."

    You may want to find out the make and model of your hard drive and download its disk checking utility from the manufacture. It will help you to better understand if your hard drive is dieing or just had an error or two.
  7. canesheadcase

    canesheadcase TS Rookie Topic Starter Posts: 24

    hey! It worked! I'm running SP2 as we speak, thanks a ton cinders! I'm pretty sure the "one or more errors" found on the hd during the chkdsk is what solved the problem, so WOO!
  8. Cinders

    Cinders TechSpot Chancellor Posts: 872   +12

    Great! I'm glad we would fix the problem. :D
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...