XP System file corrupted, cannot replace the file

By Gradient ยท 5 replies
May 28, 2006
  1. XP froze on me yesterday, and upon restarting I was informed that the file C:\WINDOWS\SYSTEM32\CONFIG\SYSTEM was either corrupted or missing. No matter what mode I tried starting XP in (Safe Mode, etc), nothing would work.

    The error message suggested I use my setup disk to repair XP, which was my first idea. Setup began just fine and started loading the setup files. HOWEVER, whereas in the past the setup disk would then give me the choice of reinstalling or repairing XP, now it simply says 'Starting Windows', exits setup, and of course restarts because the system file is missing.

    Suggestions? Laptop specs are:
    Amilo A
    Athlon 64 3200+
    1024Mb RAM
    ATI Radeon 9700

  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Test your RAM, test your hard drive. Could it be that the lappy is overheating?
  3. WinDoWsMoNoPoLy

    WinDoWsMoNoPoLy TS Rookie Posts: 252

    Happened to me before, the exact same thing.I ended up reinstalling out of frustration. You cannot copy the system file off another PC while windows is running because its a process that is always running. I probably could of fixed it though.

    Check your xp disc for the file. Look for a windows resource file site that may have it. Pretty much just find a way to replace the file.

    Nodsu: I doubt its hardware, as it wasn't when it happened to me.
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    That file is a part of the system registry. You cannot possibly copy it from another PC.

    Windows setup failing to start clearly indicates a hardware problem. Read the post again.
  5. Spike

    Spike TS Evangelist Posts: 2,168

    If system restore is enabled, you CAN copy it from a restore point though (each restore point creates a backup of the registry hive files).


    As Nodsu says though, it is very likely that there is a hardware problem here
  6. Gradient

    Gradient TS Rookie Topic Starter Posts: 32

    Thanks for the help guys; I had a local repair centre take a look at it and they also concluded that it was a hardware fault. This is the third major hardware fault in nine months, so I may have a word with Fujitsu Siemens about it.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...