XP: URL Hyperlink Problem

By Roscoe ยท 4 replies
Oct 21, 2004
  1. This has me stumped: Running XP Pro w/SP1a with Firefox 0.9.3 as my default browser. About two weeks ago clicking on a URL hyperlink started opening Internet Explorer (previously clicking on a URL hyperlink always started Firefox). I know it is something dumb that I have done - all I can think of is that I installed an update to Firefox 1.0 then elected to roll back to 0.9.3. Maybe this has reset something somewhere?

    I have tried a number of ways to repair this: reinstalling Firefox; reinstalling my e-mail client (The Bat!); removing stray registry entries; checking file assocations; setting Windows Default Access; and not one has had any effect. Clicking a URL hyperlink from within Firefox works as always - opens another tab in Firefox. It is just when I click a URL hyperlink from another application that I get IE.

    (AVG, SpyBot and AdAware are all updated weekly and can find nothing.)

    The only clue I can find is that when setting Windows Default Access (Control Panel/AddRemove Programs/Set Program Access and Defaults) the changes do not seem to stick when I press OK. In what may be a related issue I am also unable to remove MS Intellipoint 4.1 completely, so I am guessing the problem may be in the registry but sadly I lack the knowledge to wade in there and fix it.

    Would anyone care to suggest something short of a reinstall of XP?

    Thanks in advance,

  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Welcome to TechSpot

    Somehow your default-browser got changed.
    The easiest solution is this: find any file with an extension .HTM or .HTML
    Rightclick it, select "Open with" and pick Firefox from the list of programs offered. Tick the box at the bottom that says "Always open with..".
    Repeat for both HTM and HTML

    If that does not do the trick, check in Regedit:
    this should have one entry: {BB2E617C-0920-11d1-9A0B-00C04FC2D6C1}
    and in there the Default REG_SZ with value {EAB841A0-9550-11cf-8C16-00805F1408F3}

    The same applies for \.html\
  3. Roscoe

    Roscoe TS Rookie Topic Starter

    Thanks realblackstuff, your assistance is very much appreciated.

    I have checked the file associations (which were OK) and also made the suggested changes to the registry - I removed some "OpenWith" and "PersistantHandler" entries and replaced them with HKEY_CLASSES_ROOT\.htm\ShellEx\{BB2E617C-0920-11d1-9A0B-00C04FC2D6C1} with the single entry Reg_SZ {EAB841A0-9550-11cf-8C16-00805F1408F3} for both .htm and .html as per your suggestion.

    I also checked the file association for "(NONE) URL: HyperText Transfer Protocol" and it points to FireFox.

    Unfortunately the problem persists - the association with .htm and .html files works fine, but URL hyperlinks still open Internet Explorer by default.

    Could there be some other place in the registry that controls the behaviour of URL hyperlinks?

    When I Go to "Control Panel". Run "Add or Remove Programs". Near bottom left, there is a button called "Set program access & defaults". When I set preferences there they do not remain set - my suspicions are that the problem lies somewhere in there, but does anyone know what lies underneath this dialog?

    BTW, I have some services disabled as per the www.blackviper.com "safe" suggestions.

    Thanks in advance for any suggestions anyone might have.

  4. Roscoe

    Roscoe TS Rookie Topic Starter

    Boy, is my face red! I just made IE the default browser and then made Firefox the default again and it all works just fine - I was sure I had already done this, but I guess not. D'uh.

    A very humble Roscoe...
  5. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Glad you got it sorted.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...