XP "Welcome" screen problem

By olefarte · 26 replies
Aug 23, 2003
  1. Not really a problem, at least as far as I can tell, but when I boot up my computer, with XP Home, I no longer get the "Welcome" screen at startup. I get the black XP Home screen and then my monitor goes black just long enough for it to go in power save mode for maybe a second before the Windows boot song and the desktop appear at the same time. Don't know when exactly this started, but it's only been a day or two.

    Other details. Ran Norton Virus Scan, with latest updates, no problem. Use latest Zone Alarm Pro. Loaded the latest Windows updates on Thursday, now Saturday, could this be the problem? Loaded the latest Beta version of Opera yesterday. No other downloads or installations.

    While no problem is showing up, this is making me wonder what caused it. My computer is still loading at normal speed and no other problems have surfaced. Should I be worried?

    Now I have restored back to before the updates and Opera Beta, and I get a fraction of a second of the Welcome screen and then the desktop comes up. There is a message box that flashes to fast for me to read.
  2. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    Ok simple solution

    Got Start>>Run...then type msconfig
    Then on the boot.ini tab where it says boot options, untick /noguiboot.

    That should fix it.
  3. olefarte

    olefarte TechSpot Ambassador Topic Starter Posts: 1,345   +13

    Thanks for the reply, Poert. I looked where you said and it's already unticked.
  4. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    If it's a warning / error, Event Viewer might display it.
  5. olefarte

    olefarte TechSpot Ambassador Topic Starter Posts: 1,345   +13

    Event Viewer-System

    Warning-Source Dhcp
    "Your computer has automatically configured the IP address for the network card with network address ************. The IP address being used is ***.***.***.*."

    This warning always happens right after I boot my computer. The thing is, according to the times, it's thirty seconds to a minute after the desktop has loaded. Also I get this warning at more or less the same time every time. Maybe the bigger problem is, when I run a security scan with Sygate, the above IP address is not the same one Sygate shows for me, this is very disturbing. I have DSL and a external modem.

    Source-Service Control Manager
    "The following boot-start drive(s) failed to load: i8042 prt"

    Is this a virus of some kind. I'm not so worried now about the "Welcome" screen, as much as I am about a virus. The "Welcome" screen just changed and I wonder what caused it. Also another warning under security. This happened on the 19th of this month, five days ago. There were 76 security "failure audit" in a ten second period. Fifteen minutes later, another 76 times. This is the expanation that Windows Help and Support gives.

    This event indicates that the password for the specified user account (target account) was changed. This change was made by the user specified in the Caller User Name field of the message, using the old password of the target account. This event might indicate that someone is trying to get the password of another user."

    I hate to write such a lenthy post, but this has really got me worried about a virus now. I've run multiple virus scans since the MSBlast came out, and it shows I'm clean. Could I still have some kind of virus that Norton's missing? Thanks to anyone who reads all this mess, I know it's long.
  6. olefarte

    olefarte TechSpot Ambassador Topic Starter Posts: 1,345   +13

    Just rebooted and discovered that the "Warning-Source Dhcp" comes before I even connect to the internet.

    Also maybe not related, but when I go to control panel now, I have a couple of spaces where I guess there should be icons, but if there are any missing, I don't know what they are.
  7. acidosmosis

    acidosmosis TechSpot Chancellor Posts: 1,350

    Olefarte, don't worry it probably isnt a virus. Most of the time it isn't. That is just what most people automatically assume. Even if someone tells you it is, I suggest a few second opinions.

    The first thing I was thinking was you could try a restore to a point before it started happening. The thing is if you do that you will have to reinstall anything you have installed after the date of the restore point. I normally recommend restoring to the day before the problem started occuring.

    You probably don't want to do that yet, but I just thought I would suggest that if it comes to it. Restore usually works wonders. Especially when your techsupport and someone, not knowing what they did wrong changed something in their dialup settings and you just tell them hey do a restore and it saves you so much time and headache. Too bad you can't that on all Windows OS's.
  8. iss

    iss TechSpot Chancellor Posts: 1,994

  9. olefarte

    olefarte TechSpot Ambassador Topic Starter Posts: 1,345   +13

    Okay, Acid, I had already done a restore, but I went back a little farther. Still the same thing, the same error messages.

    Iss, I had already looked at the site you linked, and although the errors are listed, I didn't get a lot of useful info there, could be I just don't understand though, but really didn't find much.
  10. acidosmosis

    acidosmosis TechSpot Chancellor Posts: 1,350

    Thats not cool olefarte, hmm. I guess restore doesn't restore the files causing the problem. Which pretty much means it wasnt any drives or applications you installed and *maybe* not a configuration change.

    Have you thought about putting the XP cd in and reinstalling? Sometimes I recommend that hoping it will refresh any corrupted files. Sometimes it works. By reinstall I just mean put the CD in while in Windows and run through setup. Not sure if I have done that in XP but I used to do it in earlier versions of Windows a lot.
  11. olefarte

    olefarte TechSpot Ambassador Topic Starter Posts: 1,345   +13

    I was just thinking about that, I think there is a repair option. Might give that a try.

    The thing is, I'm not really having a problem. The "Welcome" screen is really no big deal. But after looking at Event Viewer and see all those warnings, I'm more than a little worried.
  12. acidosmosis

    acidosmosis TechSpot Chancellor Posts: 1,350

    The warnings usually are normal. It's impossible to run Windows without all those warning events. It's probably nothing to worry about because I see DHCP warnings sometimes too, along with a bunch of other things. As long as your connection is working fine then you should be ok and your running a firewall I think so I dont really see a problem. It's possible their may be one though.

    In the past I didnt pay much attention to events but lately I've been reviewing them a lot at work on our servers since I was made full admin. You would be suprised how many warnings there are in one day for different things, but our servers run fine. :)
  13. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    Warnings? In Event Viewer. I wouldn't worry about them too much, others may disagree. But probably a year or more ago I posted errors with ultra something, I've ignored it and I just now checked event viewer and its gone. Unless they are real errors or you are seeing performance problems I wouldnt' stress too much about them.
    But as always - keep the most important stuff backed up.
  14. olefarte

    olefarte TechSpot Ambassador Topic Starter Posts: 1,345   +13

    I haven't experienced any kind of performance problem at all. Everything seems normal except the unusually short "Welcome", which really is no problem, and the message box that appears almost the instant the desktop appears. It dissapears so fast, I can hardly tell it even comes up. Oh, and I do have a firewall, ZAP. Firewall and Norton AntiVirus always active.

    I hardly ever look at the Event Viewer and never even thought about it till Mic mentioned it. I guess since all the talk about the Blaster worm and others in the past week or so, I've gotten a little jumpy. Thanks everyone for your replies.
  15. Nic

    Nic TechSpot Paladin Posts: 1,549

    Olefarte, I would probably have suggested many of the things that others have already posted. I can't think of anything new to try. If I were you, then I would be a little concerned, simply because the restore option didn't help at all. My advice would be to back up any important work you have and reformat/reinstall everything. That's a pretty extreme thing to suggest, but that's what I'd do. If there are any 'trojans' lurking on your system, then that'll get rid of them. Then at least you will have peace of mind knowing your system is clean.

    PS: I you feel up to it, you might also try Lavasoft Ad-aware to see if it picks up anything strange on your system. You can find it here ...

    Lavasoft Ad-aware
  16. olefarte

    olefarte TechSpot Ambassador Topic Starter Posts: 1,345   +13

    Yeah, I forgot to mention, I've already been using Ad-aware. It didn't find anything either.
  17. Nic

    Nic TechSpot Paladin Posts: 1,549

    Go for the reformat/reinstall option then. A lot of work, but it should fix things. I'm not saying you definitely have a trojan, but it is a possibility, and I wouldn't take the risk, especially given the fact that doing a system restore failed to eliminate the problem.
  18. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    No, i8042 is PS/2 keyboard & mouse controller.
  19. olefarte

    olefarte TechSpot Ambassador Topic Starter Posts: 1,345   +13

    Thanks, Mic, at least that's one I don't have to worry about. Maybe that one is because I have a USB mouse and keyboard.

    I haven't reformated yet, still thinking about it though, but I sure don't want to.
  20. Nic

    Nic TechSpot Paladin Posts: 1,549

    Have you tried 'safe mode' to see if you get the same symptoms? Also try looking in device manager to see if anything unusual is showing up in your detected hardware.
  21. olefarte

    olefarte TechSpot Ambassador Topic Starter Posts: 1,345   +13

    Device Manager shows "1394 Net Adapter" and "Intel Pro/1000 MT Desktop Adapter" disabled, ( red X on them). I'm using an external USB DSL modem. Could this be the reason for the above warning? If it is, the IP address it shows in the warning is still not what my IP address is supposed to be.
  22. olefarte

    olefarte TechSpot Ambassador Topic Starter Posts: 1,345   +13

    I started up in Safe Mode and got quite a few errors showing up in Event Viewer, but they all look like they are caused by the USB Modem not starting up in Safe Mode. I assume the modem is not supposed to start in Safe Mode? I didn't see any of the warnings that I've been worrying about.
  23. Nic

    Nic TechSpot Paladin Posts: 1,549

    It looks like you have a network device conflict of some kind. In device manager, try uninstalling the two network devices that have a red X against them (right-click and select uninstall), then reboot and see if they get detected and the red X disappears. Looks like you're on to something here. Also try unplugging your USB modem, then plug it back in again. You might need to mess around a bit until you don't get those red X marks showing up again.
  24. olefarte

    olefarte TechSpot Ambassador Topic Starter Posts: 1,345   +13

    Nic, I did what you said, uninstalled the two network devices, rebooted and the conflicts are gone. I'm only getting one warning in Event Viewer now.

    "Event Viewer-Application

    The COM+Event system failed to fire the ConnectionMadeNoQOCinfo method on subscription (then a couple rows of numbers) The subscriber returned HResult (a few more numbers)."

    I don't know what that means, but all the warnings I was worried about are now gone. I guess the conflicts were causing the warnings. I feel a lot better now. Everybody, thanks for your help.
  25. Nic

    Nic TechSpot Paladin Posts: 1,549

    Its not easy trying to diagnose and fix problems using telepathy. Well at least the worst is over.

    For that one last error you are getting check out this link ...

    Event Viewer Entry

    Edit: Just spotted the fact that you don't have an nvidia graphics card, but you could try reinstalling the ATI drivers again (Catalyst 3.6) to see if that works.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...