xp - 'Windows Media player' not working

By canquest ยท 15 replies
Feb 18, 2007
  1. Hi. Thanks in advance for any help that you can provide.

    I have 2 accounts on my computer. Both have admin privledges. My account can select the Windows Media Player option and it works fine. (It shows up in the 'programs list'. The version that i installed is version 11.

    My son has the 2nd account. Although, there is an icon in the system tray for Windows media player, when he selects it, the hour glass shows up briefly and then nothing happens.

    Your help is appreciated.

    Thanks very much.

    ps. In a different post, I have described a similar problem with the 'Search' option.
  2. gavinseabrook

    gavinseabrook TS Rookie Posts: 320

    Go to Start>Contorl Panel>Administrative Tools>Event Viewer and check the System and Applications for any errors. Such as a service not starting or if it has an error in the media player.
  3. canquest

    canquest TS Rookie Topic Starter Posts: 19

    Thank you very much for your reply and your advise.

    I checked the log files, as instructed, and all are clean.

    The Wmp service says it started successfully. There are no errors. Yet, as mentioned, when I select it from my son's account, after the hour glass appears for a moment, it disappears and nothing happens. I have checked the event logs since (and refreshed them) and the only messages are informational messages (i.e. wmp service started successfully).

    thanks for any continuing help you can provide.
  4. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    I don`t know if this`ll help at all, but it`s worth a try.

    Uninstall WMP11, this will automatically roll back to your previous version. See if your son can then access WMP from his account and let us know.

    Regards Howard :)
  5. canquest

    canquest TS Rookie Topic Starter Posts: 19

    Howard! Great to hear from you! :)

    Ok, I followed the instructions and, using control panel add/remove programs, removed Windows media Player. It seems to have rolled back successfully.

    On my son's account, i clicked windows media player and the configuration 'wizard' (for wmp 10) displayed. I selected all the defaults and pressed next, until I selected 'finish'. Everything seemed to be fine, until i pressed finish, at which point it came back with a dialog box indicating 'An internal application error has occurred'. No other information provided. I went into the event viewer and (after doing a refresh) no errors (or even warnings).

    i also went into the service.msc program and made sure that wmp and upnp was enabled (it is, and is automatic).

    I then logged onto my own user and selected wmp. i followed the same prompts (same defaults), but this time when I selected finish, it completed successfully and started up.

    any help you can provide is great!

    Thanks (as always)
  6. sw123

    sw123 TS Rookie Posts: 595


    try moving the Media Player Config files from your working account to your sons account. Include the .exe file is it is there(Microsoft is tricky) ;)
  7. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    very strange!

    Using your sons account, reinstall WMP11 and let us know the results.

    Regards Howard :)
  8. canquest

    canquest TS Rookie Topic Starter Posts: 19

    Hi! Thanks for the suggestions.

    As instructed, I previously deinstalled wmp11 and was left with wmp10. same symptoms (works on my account, doesn't work on my son's). Then I reinstalled wmp11 and, unfortunately, the same symptoms persisted.

    I am stumped. Any suggestions would be great.

    Thanks in advance.
  9. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    I only have one more suggestion left and I have no idea if it`ll make any difference.

    Open windows media player in your account, then close it. Click start/all programmes/set programme access and defaults/custom/use my current media playe.r Make sure the Enable access to this programme is ticked. Click ok.

    If that doesn`t help, then I`m completely out of ideas.

    Regards Howard :)
  10. canquest

    canquest TS Rookie Topic Starter Posts: 19

    Thanks Howard for the suggestion. I tried it, and unfortunately there was no difference.

    After trying your suggestion, in "snooping" around I noticed the following:

    1. When i select "Select Program Access and Defaults", there are a number of other options on the side. I tried to select 'Add/Remove windows Components' and even though I am an Administrator, I get the message "The program cannot start, probably because your user account does not have permission to modify the system registry. For more information, view the application event log". Does this message mean anything in terms of my current issue?

    2. When I run 'service.msc', I notice that one of the services mentioned is 'Windows Media player Network service'. It shows that it is 'automatic', 'started' and 'logon on as network service'. Is this correct? Should it be set to 'manual'? or 'logon as local'? Are there other services that I should check?

    In any case, I too am grasping at straws. If you've run out of ideas, that's perfectly alright! Perhaps sometime in the future, something else will come to mind; if so, please let me know.

    Thank you for all your help over the last few days.

    All the best.
  11. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    I am aware that apart from your WMP problem, your having a search issue as well. Maybe your OS has been damaged by the malware that was on your system. If that`s the case, then try the following first.

    Click start/run and type sfc /scannow into the runbox and press the enter key. Windows will check for any missing or corrupt system files and replace them as necessary. You will need to have your Windows cd handy.

    Let us know the results.

    Regards Howard :)
  12. canquest

    canquest TS Rookie Topic Starter Posts: 19

    Hi again. Thanks for the latest suggestion.

    I tried it, and although sfc runs for quite a while and seems to be doing something, the result (in terms of WMP and SEARCH) is unfortunately the same. (I was surprised that after sfc runs, there is no summary report if any problems were found/fixed/etc. The progress bar window just closes and that's it).

    It seems my son will just have to live with this limitation on his account.

    Thanks again for your assistance on this one. It is a strange problem. Perhaps something will come to mind in the future.

    Until then, thanks again for the tremendous help you provided me on this and the malware problems I had earlier.

    all the best
  13. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    I`m sorry that hasn`t solved your problem.

    Maybe it`s time to try a Windows repair as per this thread HERE.

    That is my final suggestion. If that doesn`t help, I`m all out of ideas.

    Regards Howard :)
  14. canquest

    canquest TS Rookie Topic Starter Posts: 19

    Well great news! With a little bit of luck, I managed to find information on the microsoft website (knowledge site) that addressed the problem.

    Here is the link:


    (I found it originally when I searched for help on my related SEARCH problem which I posted separately on TechSpot, but it also fixed the WMP problem too).

    Thought I would post this to help the next person who might come across this post with the same problem.

  15. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    That`s great news and thanks for posting the solution.

    Regards Howard :)
  16. canquest

    canquest TS Rookie Topic Starter Posts: 19

    Oops, in my previous message, I forgot a very important first step.

    I had to first run:

    (courtesy of http://usenow.tripod.com/

    SUBINACL - tool for resetting security settings to default in XP using subinacl tool (works on XP home as well as XP Pro)

    RESET.BAT -command to run the subinacl tool


    For best results, download and save the subinacl and the reset file on your desktop
    Step 1. install the subinacl tool by double clicking on the file
    Step 2. run the reset file, note: the reset file will run for 10 or more minutes. Then restart the computer

    After running the above, I then followed the instructions found in:

    Over and out ...
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...