1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

XP wont install USB Memory Stick

By WillH ยท 15 replies
Dec 24, 2004
  1. Hi

    I have XP installed and I received a memory stick for Christmas and XP keeps telling me it cant find the drivers. It cant even find the drivers on line! I have used other memory sticks on this pc before without any problems but now none of them seem to work or install.

    I checked the memory stick out on my laptop and it works fine. I am running XP Pro Service Pack 2. I would appreciate any help anyone could give me.

  2. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,377

    Several other people here have had problems with Service Pack 2 corrupting their USB system finles. Try reinstalling the USB drivers or your motherboard chipset drivers.
  3. WillH

    WillH TS Rookie Topic Starter


    Thanks for replying. I downloaded the chipset drivers from Dell for my pc and installed them but to no affect. As far as I know the USB drivers were included with the chipset drivers, or am I wrong?
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    USB drivers come with chipset ones.

    You could try uninstalling all the USB related devices in Device Manager and then reinstalling the latest versions.
  5. WillH

    WillH TS Rookie Topic Starter

    I would be afraid to uninstall any USB reladed devices just in case I couldnt reinstall them again. Do you think that I would be able to reinstall them again?
  6. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,377

    The USB drivers are part of the chipset drivers but they dont always install on their own. Go into device manager and right click on the USB controllers and choose update driver.
  7. WillH

    WillH TS Rookie Topic Starter

    Hi vegasgmc

    On your advice I did that but I keep getting the same thing 'Cannot Install this Hardware' . Although under USB Controllers there is a USM Mass storage device listed. The driver for this is located in windows\system32\drivers\. When I install the software from location and use this address it still will not install. Aghaaaa!! ;-)
  8. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,377

    All of the newer USB drives had their drivers in firmware. You only need drivers if you're using Win 98. What chipset do you have? I had a KT600 board with VIA chipset and I had to get a seperate USB driver from Viaarena.com.
  9. WillH

    WillH TS Rookie Topic Starter

    I have a Intel P4 3Ghz running Windows XP Pro. How can you find out mre info on the chipset? If you only need drivers for windows 98 why does my pc keep looking for the drivers??

    I tried to install a Philips MP3 player tonight. It has a 20Gb harddrive so my dell should have least picked it up as a mass storage device, but it didnt. I get the same thing 'Cannot find drivers'.
  10. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,377

    You have an Intel chipset. You can go to Dells website and put in your model number and it will tell exactly what you have. Have you tried the Dell support forums? It sounds like a driver or Windows problem.
  11. WillH

    WillH TS Rookie Topic Starter

    Ya I tried the forums and I saw one guy with the same problem. They recommended that he uninstall all usb devices etc reboot and let windows reinstall them. The problem is I am afraid to do this as I have a all of my usb ports in use and I dont want to end up having nothing working. I have searched the entire www and have not found a resolution to this problem. I am in the hands of the people of this forum.

    I also have a Mass Storage Device in my watch which is very handy. This still works no problem at all. I cant understand what the hell is up.
  12. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    You are in Dell-Hell.
    Do as advised on the web. Make a Restore-point, and uninstall all USB-devices etc. Upon reboot, Windows WILL reinstall the lot. You may have to re-install perhaps mouse- and/or scanner-software, but that's about it.

    And you still did not specify WHICH USB-key you are trying to install.
  13. WillH

    WillH TS Rookie Topic Starter

    I am trying to install a Apacer Handy Steno HT202. I will give the reinstall a bash. I will let ye know how I get on.

    ........No Joy. Nothing would install after I uninstalled all USB devices not even the mouse. Same story 'Cant find drivers'. I had to do a restore.
  14. WillH

    WillH TS Rookie Topic Starter

    Just tried to install a Sony Digital Camara on the same PC. I am getting the same problems even though I have the drivers on cd. It still says that it cant find them. This is really starting to piss me off.
  15. dafunkep

    dafunkep TS Rookie

    i have had the same problem as you on my brothers machine trying to use a mp3 player but works on the other 2 machines in the house and have still not found the solution to this. It has something to do with the VIA chip set but untill you find a update for the bios the only way to solve the issue would be to get a decent USB controller card im thinking. :chef:
  16. WillH

    WillH TS Rookie Topic Starter

    Hi dafunkep and everyone else.
    I sorted out the problem unfortunately it took a reinstallation to sort it out. I couldnt find anything on the Dell forums to sort out my problem so I rang Dell tech support. Everything they reccommended I had already done so the reinstallation was the only option. Bummer!!
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...