TechSpot

500gb drive in Xtrastor enclosure, drive reads as 8gb

By megamawax
Sep 27, 2008
Topic Status:
Not open for further replies.
  1. Hello,

    I purchased 2 500gb Maxtor SATA hard drives. The first I installed internally, and it works fine. The second I installed inside an Xstrastor dual-bay external enclosure. The enclosure can connect via eSATA or USB. This drive is detected but is read as being only 8gb, whether connected via eSATA or USB. The enclosure is a raid enclosure, but I thought that if only one drive was installed in the enclosure, it would just be read as a single drive. I think I remember reading something about an 8gb limit on some old hardware, so perhaps I need a driver. My equipment is fairly new - MSI P6N Diamond motherboard, NX8800GT video card, 4gb Corsair XMS2 DDR2 memory...anyone have any ideas?

    Thanks.
  2. megamawax

    megamawax TS Rookie Topic Starter

    Well, this was fixed, sort of. After holding down a reset button for 10 seconds, my drive is being detected via USB. However, it is no longer detected at all through onboard eSATA or eSATA adapter.
  3. megamawax

    megamawax TS Rookie Topic Starter

    I've solved the problem. My motherboard comes with seven internal sata ports. Ports 6 and 7 are for RAID. I had to plug in the eSATA adapter into one of these ports to get it to work.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.