TechSpot

64-bit and RAM problem?

By Guru1294
May 25, 2010
  1. Ok i gotta slight problem.

    Apparently when i go to system specs in windows 7, it says i have 4.00 GB of ram but ony 2.97 is usable? What the heck. What happened to the rest.

    Now i did do a little research and what i found was that this problem should only be occurring on 32 bit operating systems. But i have 64 bit !!! What gives?

    This never happened to me earlier. My windows index score is still the same.

    I also checked back on my update history and here's what i found:

    Update for Windows 7 for x64-based Systems (KB981793)

    Installation date: ‎25/‎05/‎2010 3:35 PM

    Installation status: Successful

    Update type: Important

    Install this update to resolve issues caused by revised daylight saving time and time zone laws in several countries. This update enables your computer to automatically adjust the computer clock on the correct date in 2010. After you install this item, you may have to restart your computer.



    can anybody please help.
    I really appreciate it.

    Specs will be provided upon request.
     
  2. myrmidonks

    myrmidonks TS Rookie Posts: 48

    The missing RAM is being used to run the operating system and any other applications you might have open at a given moment (e.g. virus protection).
     
  3. brucethetech

    brucethetech TS Enthusiast Posts: 229

    what kind of computer or mobo is this? your mobo manufacturer has max specs that override the OS max ram specs.
     
  4. Guru1294

    Guru1294 TS Rookie Topic Starter Posts: 32

    Just to clarify things, i think this happened after an update because earlier for 3-4 months i never saw this appear and what is a mobo please specify
     
  5. red1776

    red1776 Omnipotent Ruler of the Universe Posts: 5,219   +157

    mobo= motherboard, may be listed as 'mainboard' as well
     
  6. Guru1294

    Guru1294 TS Rookie Topic Starter Posts: 32

    im not sure. I have been trying to find out. If it helps i can give you my pc manufacturer and exact model number because i had no luck finding what my mother board was.
    Anyways its an Hp laptop DV-6 1238ca
     
  7. mailpup

    mailpup TS Special Forces Posts: 6,979   +362

    It seems it is being used mostly for video memory. From the HP website: Video Memory Up to 2302MB (512MB dedicated) For reference: HP
     
  8. Guru1294

    Guru1294 TS Rookie Topic Starter Posts: 32

    Would'nt that be taking space from the paging file? not the ram
    Apparently it should be fine if you enable memory remapping in the bios, but i don't have that feature in bios :(


    BTW I appericiate you guys trying to help me.
    This problem is getting on my nerves
     
  9. Guru1294

    Guru1294 TS Rookie Topic Starter Posts: 32

    I just found something in resource monitor. Apparently 4096 mb of ram, 1057 is reserved for hardware, around 1222 is in use 54 is modified 1636 is in standby and 127 is "Free".

    Total adds up to 4096.

    Now my only question is that. Is this a normal thing to have 1057 mb reserved for hardware or is this just my system. I don't have memory remapping feature in bios which sucks.

    pLease leave comments and if possible help me to enable memory remapping without bios. If not, well im gonna have to live with it

    Thanks for all responses
     
  10. red1776

    red1776 Omnipotent Ruler of the Universe Posts: 5,219   +157

    Are you absolutely sure you have a 64 bit version of 7? what you just described sounds exactly like memory mapped reservation. it lets you use somewhere between 2.75 and 3.25 Gb of 'working memory' and reserves the rest for things like pci buses, installed hardware, etc
     
  11. captaincranky

    captaincranky TechSpot Addict Posts: 11,691   +1,879

    I Know Next to Nothing About Laptops....

    Admission absolves guilt, now I can charge in without responsibility for my actions.

    Is it possible the the motherboard is 32 bit hardware...?

    We had another thread along these lines and it turns out there was a setting in BIOS to enable the extra RAM option.

    Vague, I know. Plus, I'm rather old and doddering, so I can't come up with the correct search terms to find the aforementioned thread.

    Suggest an Email to HP support.

    Alternate Universe; If you think it was an update that caused this problem, then remove it. Go to programs in "control panel", click on "shop updates", then uninstall the update. This brought to you by the "If Thy Right Eye Offends Thee, Pluck it Out", school of computer repair. (not licensed or accredited in any state).

    The system clock resides in the BIOS, so one supposes there could be a connection between two seemingly unrelated actions.

    Personally, I saw the offer of this update, looked at the clock on the taskbar, saw that it displayed the correct time, and ignored it.
     
  12. Guru1294

    Guru1294 TS Rookie Topic Starter Posts: 32

    Yea i don't seem to be understanding why i 1057 mb is hardare reserved usually it shouldn't be more than 100 mb. I can definitely confirm i have 64 bit. If you need screenshot please post. please also tell me how to take a screenshot and upload it here.

    Thanks
     
  13. Guru1294

    Guru1294 TS Rookie Topic Starter Posts: 32

    yes in system properties i have 64 bit os and my machine is an x64 not x86
     
  14. Guru1294

    Guru1294 TS Rookie Topic Starter Posts: 32

    its not my graphics card i believe because it only uses shared memory when required and that too from the hard disk. Its onboard but ha 512 dedicated memory
     
  15. captaincranky

    captaincranky TechSpot Addict Posts: 11,691   +1,879

    In 32 bit operation 1057 MB reserved for hardware addresses is quite normal.

    Go into BIOS and look around. Don't change anything. Just see what options exist for the control of memory. Share this with us.
     
  16. Guru1294

    Guru1294 TS Rookie Topic Starter Posts: 32

    No memory remapping options. Ram is shown at 4096 mb. I have checked this before. but still i did it again if i could find something again. Also i just updated my bios recently but things are still the same :(
     
  17. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    The product specifications at HP site say "Video Memory Up to 2302MB (512MB dedicated)", that's what eating up your RAM.

    The BIOS should/might have options for controlling the amount of shared RAM (I remember my old HP NX6125 having that option). If it doesn't, maybe a HP utility in Windows does?
     
  18. Guru1294

    Guru1294 TS Rookie Topic Starter Posts: 32

    No actually there is no such application that i have to enable memory remapping or somehow tell windows to use all the memory

    THanks for the idea i actually discovered a lot more applications on my computer that otherwise i never knew about
     
  19. jmjsquared

    jmjsquared TS Booster Posts: 144

    Missing Memory

    Guru1294,

    Your computer is definitely a 64bit and should be able to address up to 8GB of memory. The update KB981783 is probably NOT the problem.

    Please go to HP's Support Website to update your BIOS:
    http://h10025.www1.hp.com/ewfrf/wc/...dlc=en&cc=us&os=4063&product=3979372&sw_lang=

    Their Description:

    " WinFlash for HP Notebook System BIOS (for Notebooks with Intel Processors)
    2009-11-06 , Version:F.41 A, 2.13M (‏Previous versions available)‏
    This package contains the WinFlash Utility and a System BIOS image for the supported notebook/laptop models and operating systems. The WinFlash Utility is used to locally flash the System BIOS on notebooks/laptops operating in a Microsoft Windows Vista or Windows Operating System environment. "

    I believe this will solve your problem.

    Good Luck.
     
  20. Guru1294

    Guru1294 TS Rookie Topic Starter Posts: 32

    Sorry to burst your bubble but i recently updated to that version (F.41)

    But very good try.

    I made sure to keep things in mind before making this thread and this was one of them

    Thanks for your help\

    There was basically no change in the bios screen

    All of the options were there, no new ones.
     
  21. jmjsquared

    jmjsquared TS Booster Posts: 144

    Smart and wise and obviously well-bred

    Have a good one. :wave:
     
  22. Guru1294

    Guru1294 TS Rookie Topic Starter Posts: 32

    Anyways if no has ideas as to what exactly this could be then i guess im gonna have to live with the fact that 4gb ram is not fully usable
     
  23. Guru1294

    Guru1294 TS Rookie Topic Starter Posts: 32

    HOLY **** I found the cause. EVERYBODY WHO HAS THIS PROBLEM PLEASE READ!!

    If you are having the same problem as me, i have the answer (Works only for 64 bit users)

    Go to start menu > type Msconfig > Boot> Advanced > Uncheck maximum memory

    Hopefully it worked for everybody with this problem

    To double check Go startmenu> type resource monitor and you should see all you memory being used.

    To triple check go to system properties and it should say that all the installed memory is being used. not (2.97,2.99 etc etc)
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...