TechSpot

Access Point Recognized/Wireless Adapter Working: Can't Connect to the Internet

By Route44
Jun 9, 2010
  1. The wireless internet aspect of my daughter's laptop failed. It is a system board malfunction.

    I purchased a USB wireless adapter to overcome the issue and after installation it immediately connected to the access point which is connected to my wired Linksys router.

    Cliff Notes:

    1. Went to connect wirelessly in another room. No connection.

    2. Unplugged the power to router, modem, and access point for 15 seconds in order to reset. Did not resolve the issue.

    3. Access point is recognized by the laptop and shows it connected and signal good.

    4. Wireless adater in device manager recognized and fully working. It is "Device funtioning properly."

    5. Attempted to do a repair several times but here is the repeated message: "Connot connect with DNS server. Network Diagnostics pinged the remote host but did not receive a response."

    So, Access is functiong and recognized by the laptop as connected and signal is good. The wireless adapter is recognized as fully functioning. Yet I can't receive a response.

    Advice please. Networking isn't anywhere near a strong area for me.

    * One other thing. My old Toshiba laptop connects with its a/b miniwireless card.
     
  2. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,374   +167

    I assume your using some encryption mode? (WPA, WEP, etc.)

    1. Make sure by the access point and the wireless adapter are set to use the same mode
    2. Have you entered the network password correctly?

    If any doubt, see if your router lets u backup its setttings. Then turn off all encryption in both the AP and adapter and see if they connect then (easiest way to prove it's an encryption issue )
     
  3. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 12,167   +37

    Encryption: WPA-2

    I am almost 100% sure the network password was entered correctly because after the initial install the wireless adapter immediately connected to the Access Point. The connection was strong.

    To make sure, how do I go about in Vista to find the mode the wireless adapter is set at? I found the TP-Link folder but could not find the information to answer your inquiry.
     
  4. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    with both a Router and an A/P, the A/P is usually set for Bridge Mode to allow the settings
    from the Router to be sent via DHCP to all new contections ...
     
  5. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 12,167   +37

    jo, pardon the ignorance but could you explain further? Netwoking is something of which I have very little working knowledge.

    I did come across Bridge Mode in the Vista Networking troubling shooting. Should I look in there?
     
  6. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    As I understand, the process goes like this
    1. disconnect the A/P from everything
    2. then wire a connection from it to any system
    3. access the default address
    4. login with user/password
    5. find the settings for the WiFi and set the SSID + CHANNEL you want
    6. find the uplink connection settings and set Bridge mode
    7. save the settings which will break you connection
    now disconnect the system from the A/P & connect the A/P to the router.
    your wifi should now be able connect.

    Run->cmd and enter
    ipconfig /all
    and the gateway address should be that of your router

    and ping www.google.com should return timing info
     
  7. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 12,167   +37

    This post edited and deleted by OP due to brain lock.
     
  8. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,374   +167

    1) Did you leave something off? As your wireless adapter isn't listed in ipconfig /all (If it's really not listed, then the driver isn't working) so i'm guessing you didn't include it??? as your post sounds like the driver should be there (unless you since uninstalled it)

    2) Do you really have an AP or is it a wireless router? In any case, what's the make model of your wireless device? (so we can confirm what it is)

    3) Are you actually seeing your SSID on Vista when you view available wireless networks? /* Edit start */ I'm assuming you did based on your post /* end */ (if you are, then it's most likely an encryption/security issue unless you specifically config'ed your AP to not broadcast the SSID)

    4) http://technet.microsoft.com/en-us/library/bb878035.aspx

    5) If you're seeing the SSID, IMHO: the next simplest step between you and success is first turning off all the layers of wireless security
    > Network passwords
    > Encryption method
    > Access control lists by MAC addresses
    To simply prove you can see the SSID and click on it to connect. Then start putting the layers back on 1 at a time and proving you still connect with each new layer

    /* edit */
    I'm assuming, based on your post, that your wireless card installation was just a driver and didn't inlude a wireless connection manager. In which case, Vista will be using the Windows' wireless manager. so i provided the link above
     
  9. tipstir

    tipstir TS Ambassador Posts: 4,686   +86

    What did you buy to replace the onboard duff wireless with? What OS are you running?
     
  10. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 12,167   +37

    Vista 32-bit Home Premium. Replaced the wireless mini wireless with TP-LINK TL-WN727N IEEE 802.11b/g/n USB 2.0 Wireless Adapter Up to 150Mbps Wireless Data Rates 64/128 bits WEP WPA/WPA2, WPA-PSK/WPA2-PSK (TKIP/AES).

    To LookinAround's Questions:

    1. No, I left nothing off. I came across the thread where jobeard and you were helping someone and you happened to provide cmd /c ipconfig /all > "%userprofile%\desktop\ipconfig.txt" from which I posted every bit of information (except the physical address). And I did not uninstall the wireless adapter. As noted earlier it is seen in the device manager and working fully. Also, the first time I installed said adapter it immediately connected with the Access Point with absolutely no issues connecting to the internet..

    2. This is an Access Point connected to my wired Linksys router. The name and model is TRENDnet Wireless Easy-N-Upgrader TEW--637AP.

    3. Yes, we see the SSID on Vista. Laptop shows we are connected and the signal is good.

    I appreciate everyone's help. I can build systems, fix them to a degree, and read minidumps but as I stated before I am in a whole new area that I had never had to deal with before.

    I'll attempt to some time tomorrow -- if I even have the time -- to look into # 4 and 5.

    Question: Would simply uninstalling and reinstalling the wireless adapter have the possibility of rectifyingthe issue, or is simply a dream on my part? ;)
     
  11. tipstir

    tipstir TS Ambassador Posts: 4,686   +86

    Tell me you didn't use the CD driver did you? If you did remove it! Realtek chip in there. What you did is pull the driver down from the internet. Pull the driver from the internet. N150 is TX: 150mbps / RX: 150mbps. I have the clones also made by Airlink. Tricky to get it work under 7 64-bit their site tells me so such driver is available. But there is one. I have now on 32-bit 7 laptop and got driver off the internet using MSW7-update.

    Also not USB port with one of these devices can be odd too. Try changing USB ports also disable power saver feature if you have such a feature. Make sure your router is set to 802.11g/n mix mode.
     
     
  12. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 12,167   +37

    By saying CD driver you are referring to the TP Link adapter, correct? If so, yes I used the CD driver. I happened to check on their website their driver updates for this device and was somewhat suprised to see the latest and last offered at this point is from November of 2008.

    I wasn't sure where I should pull drivers from other than TP Link's site. Also, could you please show me where the Realtek chip is to be found in the specs provided? I'm not doubting but I sure would like to know where you pulled that from.

    I'll try another USB port tomorrow. You said: Make sure your router is set to 802.11g/n mix mode.

    My router is a wired 5 year old Linksys G router and my Access Point works well with it providing wireless access throughout the house. I don't know how I can set the router to 802.11g/n mix mode since the router is only G.

    By the way, thanks for your input.
     
  13. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,374   +167

    While i learn anything may be possible with computers.. i'm really surprised that you have a wireless driver installed for the device yet the wireless device doesn't appear in ipconfig /all

    Maybe i'm learning yet another Windows anomally but could you please
    1) double check your ipconfig /all output (there's no wireless device listed???)
    2) Check Problem Device report
    • Make sure all your devices are connected and powered on
    • Click Start->Run, enter: msinfo32. Click the + sign next to Components to expand it
    • Click Problem Devices. Anything appear?
    • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post

    3) Look in DevMgr. You see 2 network adapters listed? Both a LAN and Wireless device? Rt click wireless, look on General tab. device status=Working Properly??

    /* edit */
    Tho i you say the laptop is seeing your Wireless SSID??? as then it should have a working driver and device should appear in ipconfig /all. I'm stumped
     
  14. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,374   +167

    WAIT A MINUTE! I'm even more confused!

    Something else just ocurred to me. You say you're using Vista??? Because your ipconfig /all output looks like all ipv4 addressing (e.g. in XP). Or did you expressly turn off all ipv6 functionality in Vista?? (because it's turned on by default)

    Are you seeing the SSID at all on the computer with the problem??? Or you mean you see SSID on other computers??? As if you're not seeing the SSID (or any SSID?) on the computer with the problem, then you definitely have a missing driver (and things begin to make sense again :) )
     
  15. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 12,167   +37

    Nothing to be seen here; move along...
     
  16. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 12,167   +37

    Okay, here is MAJOR, MAJOR, we're talking MAJOR embarresment on my part. I'm talking MAJOR. We're talking low grade imbecile thinking here: I am so tired I've accessed my own computer concerning IP Config!!! DUH! Stupid! I read far too many minidumps. I am glad you are awake because I am comotose.

    Why did I do that? Just shoot me. But I am AM correct in that her Vista machine a) recognizes the Access Point and b) the wireless adapter is recognized in her device manager, and c) this is true of this laptop and not my PC: Attempted to do a repair several times but here is the repeated message: "Connot connect with DNS server. Network Diagnostics pinged the remote host but did not receive a response."
     
  17. tipstir

    tipstir TS Ambassador Posts: 4,686   +86

    I've seen this issue before even with mine yesterday. Does your blue amber light or green does it even come on? By default the adapter will be in 802.11b/g/n mode, unless it has 802.11g mode. But I doubt it. If you have the same chipset then I do then you be able to let Windows V pull it off the internet for 5/2010 driver. The 2008 driver is acting up on you.
     
  18. tipstir

    tipstir TS Ambassador Posts: 4,686   +86

    Relax I like the way you think and still keep up a upper lip with some humor. Still no one perfect in IT sense..
     
  19. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 12,167   +37

    Thanks tipster! If one can't laugh at one's own dumb mistakes it's a sad day indeed. Here was the original issue with the laptop. Up until 6 months ago her system's wireless worked fine. (We purchased it back it May 2007) Long story short came to find out we purchased one of HP's DV6000 series and they had tremendous fail rates due to the Nvidia chipset. System board after system board had to be replaced.

    We've been fortunate that hers has lasted three years in collge and we probably will get one more. But came to fine out that after 3 years or so hardware on these Compaqa begin to fail and the wireless Mini card fails because it is a system board fail. HP told me so and so did a techie.

    The light was always Amber. I switched out cards but that didn't rectify the issue. Thus the USB wireless adapter. The green light does come on in the adapter. Tomorrow I'll check the driver's date that is installed. Yes, it does say that the driver is present.

    Thanks again. By the way, I have an older PC system that I want to discuss with you to see if the hardware can be used for a home theater system. But that is for another time and thread.
     
  20. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,374   +167

    LOL. That was a good one... ;)

    But no worry... We all have those occasional moments!

    As long the clear and coherent moments far outweigh the dumb ones (as they certainly do in your case) it all just makes for a good laugh :) (and all the funnier because you sure did have me very confused, for awhile there, trying to figure out what was going on! LOL)

    Re: The drivers
    Do start with a look at the drivers as tipstir says he has experience with this adapter. But let me add:
    > Open DevMgr, rt click the device. Select Properties->Driver
    > What Provider, date and version is listed?

    That should tell you which driver is installed
    > If provider is MS, you're running a Windows generic driver (which you would't want in this case)
    > Otherwise, you can usually compare the vendor/version/date to the drivers on the vendor's web site to know what you got (i.e. if it;s an old/wrong driver version)
     
  21. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    Oops! With that setting, the device will not even ask for the DHCP data!
    Let me lookup the fix ...
     
  22. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 12,167   +37

    jo - let me save you the trouble my friend. Take a look at Post #16 and it will explain it all. :blush: :eek: :eek: :blackeye:
     
  23. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    NodeType controls the name resolution request and the values are shown here
    Code:
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\NetBT\Parameters\NodeType RegDword = 8
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\NetBT\Parameters\NodeType RegDword = 8
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Parameters\NodeType RegDword = 8
    you will need to reboot to make it effective and then ipconfig /all will show
    Node Type . . . . . . . . . . . . : Hybrid
     
  24. tipstir

    tipstir TS Ambassador Posts: 4,686   +86

    Route44 where are you at now with this issue? Did you disable onboard NIC wireless that was faulty in the BIOS?
     
  25. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 12,167   +37

    Riddle Me this Batman

    Okay guys, riddle me this. I have not had the time to put aside to troubleshoot an issue and follow the advice you all gave me. Life has been crazy busy. Anyway...

    My daughter decided to use her computer today and this is the first time she has used it since the wireless adapter didn't work. She said she would see if it would connect. AND IT DID. The only thing different is she moved from the kitchen table to the living room 15 feet away. Yet my Toshiba is still at that table and it continues to connect via it's a/b wireless card.

    The single is strong and has been steadily connecting for going on three hours now. :confused: yet :) Do you see anything in the information below that is telling? Thanks.

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : Rebecca-PC
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Peer-Peer
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : hsd1.nj.comcast.net.

    Wireless LAN adapter Wireless Network Connection 2:

    Connection-specific DNS Suffix . : hsd1.nj.comcast.net.
    Description . . . . . . . . . . . : TP-LINK TL-WN727N Wireless Lite-N USB Adapter
    Physical Address. . . . . . . . . : 94-0C-6D-E2-8D-BD
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::55fd:32da:5d00:6f39%14(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.1.100(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : Wednesday, June 16, 2010 1:42:56 PM
    Lease Expires . . . . . . . . . . : Thursday, June 17, 2010 1:42:52 PM
    Default Gateway . . . . . . . . . : 192.168.1.1
    DHCP Server . . . . . . . . . . . : 192.168.1.1
    DHCPv6 IAID . . . . . . . . . . . : 311692397
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-0D-E4-E8-55-00-1B-24-11-EA-9D
    DNS Servers . . . . . . . . . . . : 68.87.64.150
    68.87.75.198
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Local Area Connection:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . : hsd1.nj.comcast.net.
    Description . . . . . . . . . . . : NVIDIA nForce 10/100 Mbps Ethernet
    Physical Address. . . . . . . . . : 00-1B-24-11-EA-9D
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 7:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . : hsd1.nj.comcast.net.
    Description . . . . . . . . . . . : isatap.hsd1.nj.comcast.net.
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 9:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
    Physical Address. . . . . . . . . : 02-00-54-55-4E-01
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:20b2:28a3:3f57:fe9b(Preferred)
    Link-local IPv6 Address . . . . . : fe80::20b2:28a3:3f57:fe9b%10(Preferred)
    Default Gateway . . . . . . . . . : ::
    NetBIOS over Tcpip. . . . . . . . : Disabled
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.