Acer Aspire One ZG5 issue

By metalronin
Feb 9, 2010
Topic Status:
Not open for further replies.
  1. Hello i have an acer zg5 netbook one day it just died from a low battery tried charging it and after a few hours it failed to turn on power button lit up for a sec hard disk light flashed then nothing tried to plug it back it and the led says it was charging then would turn green saying it was charged but still would not turn on. I replaced the power cord and all that still happens. (the screen was recently replaced by me but it had worked fine for several days after the fix including holding a charge.). I thank anyone in advance for help.
  2. metalronin

    metalronin Newcomer, in training Topic Starter Posts: 47

    Anyone have an idea?
  3. Archean

    Archean TechSpot Paladin Posts: 5,985   +66

    From your post I am deducting that your battery probably has died; as you say the power LED is turned on and it indicates that its charging.
  4. metalronin

    metalronin Newcomer, in training Topic Starter Posts: 47

    Thanks ill take a look around for a new battery :) ill post back with my results
  5. Archean

    Archean TechSpot Paladin Posts: 5,985   +66

    Welcome; but I want to ask one more thing; does your netbook turns on normally when turned on while power plugged in?
  6. metalronin

    metalronin Newcomer, in training Topic Starter Posts: 47

    No it does the same thing if the cord is plugged in : /
  7. Archean

    Archean TechSpot Paladin Posts: 5,985   +66

    I'm afraid to start with you need to get your ac adapter checked, then move on to onboard power unit; battery, etc.
  8. metalronin

    metalronin Newcomer, in training Topic Starter Posts: 47

    My original ac adapter was a bit old and had some wear spots on the cord I replaced it thinking that was the problem but even with the brand new adapter it still does not work :(

    How would i check the on board power unit?
  9. Archean

    Archean TechSpot Paladin Posts: 5,985   +66

    Do you hear any beep by the way?

    Are you sure that power cord is OK?

    Probably the adapter jack (on the netbook) is loose/or is disconnected from the motherboard, as many manufacturers use cheap/junk jacks (and charge much higher replacement prices for them); if that is the issue, I'm afraid you'll have to take it to a technician.
  10. metalronin

    metalronin Newcomer, in training Topic Starter Posts: 47

    No beeps, the cord has a status led on the adapter box that lights up green im assuming that means the cord is good. Ill have to look into the jack being bad thanks for the info
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.