TechSpot

Acoustic Edge 5.1 & Live! user help needed

By TS | Thomas
Apr 1, 2002
Topic Status:
Not open for further replies.
  1. I'm updating the Soundcard guide at the moment & it would be great if anyone using the latest WDM driver (Or the latest BETA from Turtle Beach or Philips) with the Live! or Acoustic Edge could check the images of their Control Panels against the ones currently in the guide http://3dspotlight.com/tweaks/soundcard/print.shtml
    If the newer Drivers contain updated control panels could you please email a screenshot of the ful control applet. Preferably 24-bit Bitmap in zip/rar format. You can take screenshots by clicking on the control panel & pressing ALT+PRINT SCREEN. Paste that into MS Paint then.

    Thanks guys.
  2. dylman

    dylman Newcomer, in training

    I have the Videologic Sonic Fury - it ran fine under WinME (identical to the driver in your article), but the driver choked and died when I installed XP a month or so ago. After a lot of hair pulling and gnashing of teeth I installed the Santa Cruz drivers (21 Mb on a dialup!) version 5.12.1.4142 and have been happy ever since. The only difference I've spotted is that the hardware mp3 acceleration option is gone, but that's irrelevant anyway.

    Needless to say Videologic upgraded their drivers to be XP-friendly about 3 days later. :rolleyes:
  3. TS | Thomas

    TS | Thomas Newcomer, in training Topic Starter Posts: 1,327

    The Videologic card "is" a Santa Cruz, just some distribution thing they have going on, so I wouldn't bother with using videologics drivers as such.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.