ATI Mobility Radeon X1300 problems...

By SinbadX
Jul 31, 2007
Topic Status:
Not open for further replies.
  1. Hello, I'm new arround here so this is my 1st post!
    I'm having some problems with my laptop, I bought an AcerAspire 5600 recently and it worled fine... but now I can't run any game or program that requires a video card because the laptot shots down after a few seconds :s and I used to work with those same programs fine while ago... A friend told me that it would be probably problems with the video card, but I can't figure it out, I've tried to update the drivers but can't do it, so I'm doing something wrong...
    Can somebody give me a step-by-step help :p
    Thank you!
  2. pdyckman@comcas

    pdyckman@comcas Newcomer, in training Posts: 718

    Go to ATI/Radeon website. Look for 'support/download drivers'. Enter the required information (usually the # of the graphics card and operating system that you have). You should see the 'download drivers selection there. Download that. Good Luck.
  3. lovuin2

    lovuin2 Newcomer, in training

    yes i have
  4. Rage_3K_Moiz

    Rage_3K_Moiz Sith Lord Posts: 7,281   +24

    Since you bought the laptop recently, I'm assuming it has Vista installed? ATi doesn't provide driver support for Mobility Radeon cards. Drivers are only provided by the laptop manufacturers. Look here for your laptop's video drivers.
    Also, your GPU might be getting too hot, which might shut the PC down. In addition, are you trying to run the game on battery? Try running it while the laptop is charging. If all that fails, take the laptop to the workshop.
  5. SinbadX

    SinbadX Newcomer, in training Topic Starter

    hi folks!
    Thanks for the help, but it seems that the board is damaged, so the laptop it's going back to the store!
    Bye...
  6. resu

    resu Newcomer, in training Posts: 218

    i had a recent trouble with my x1300 mobility card .. Media center said taht i was using my gfx card to copy dvds (which i wasnt) and so i couldnt watch any film
    my lappy is also an acer
    i just restarted and then turned off all teh radeon extras (the background programs) and then MCE liked me again
    i tried to update the drivers but it says taht i dnt have a ati card lol

    thinking about sending my lappy back aswell once i get my new pc built
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.