TechSpot

Battlefeild 2 freezes

By PISSED
Dec 25, 2005
  1. I'm officially pissed,during gameplay the computer freezes, the fans working, my power supply is sufficient.Specs are-AMD 64 3400 processor,RAM 512mb,200gb harddrive 7200 rpm,Nvidia Geforce FX52000XT AGP,computer is a HP media center PC m1160n, I restored the computer 2 times in the last 2 months and it never helped,I ran virus scans and came up with nothing,its been doing this for about 4 months, and happens usually during battlefield 2, and sometimes it randomly reboots itself,any help would be awsome,thanx.
     
  2. Mazza558

    Mazza558 TS Rookie Posts: 35

    Have you got the latest drivers and patch for BF2? Or, your GPU is getting overloaded with the amount of textures in BF2.
     
  3. swker98

    swker98 TechSpot Paladin Posts: 1,077

    I tihkn the problems is with your viedo card, in battlfld 2 requeirmants it requires a 5700 or better
     
  4. Mazza558

    Mazza558 TS Rookie Posts: 35

    Yeah, Get a new graphics card. I know your system, so it will have an AGP slot and will need a new PSU for really good graphics cards (yours is 250w)
     
  5. PISSED

    PISSED TS Rookie Topic Starter Posts: 22

    the game wants me ta download a 5200, thanx I'll get a 5700
     
  6. swker98

    swker98 TechSpot Paladin Posts: 1,077

    i would get a 9600pro insted of a 5700 as it will preform better and is about tthe same priise
     
  7. PISSED

    PISSED TS Rookie Topic Starter Posts: 22

    My cousins got the same computer, and doesn't have this problem, he has a stock computer with the same specs as mine, but, haha, durin game play it doesn't lagg on mine. though i haven't bought the card cuz my cousin doesn't have the problem, so there might b a way to fix it without spendin money
     
  8. swker98

    swker98 TechSpot Paladin Posts: 1,077

    have you ran virus and adware scans, go to the internet sucrity fourm on techspot and follow all the READ posts by REALBLACKSTUFF also to stop it from rebootig automadily hit windows key+ Break key and go to Advanced-Settings- and uncheck Automarily restart

    Also what are the Temps of your computer, these can be found in BIOS
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...