TechSpot

Battlefield 4 Official System Requirements

By Jad Chaar
Sep 9, 2013
Post New Reply
  1. The official requirements are out and they are very pleasing. The game can run on a GPU as old as a ATI Radeon 3870. This means that people with older PCs will still be able to join the battle. This is good news for me since my GPU is not the strongest. The fact that you need a 3GB GPU (recommended) in order to play on ultra is interesting though.
     
  2. St1ckM4n

    St1ckM4n TS Evangelist Posts: 2,920   +627

    3GB is required for dat lens flare.
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...