TechSpot

BIOS not installed, Drive not found!!

By MightyKing
Jul 26, 2007
  1. Hi, i had the same problem as in this thread (http://www.techspot.com/vb/showthread.php?p=477868&posted=1#post477868),

    i fixed it by going into BIOS setup.

    I went to 'Advanced' then to 'Onboard Devices Configuration' and disabled it.

    This got rid of my "BIOS is not installed" problem.

    What i did, is that .--->
    ???


    Well if that is fixed, i do still have another message appearing when i start my pc.

    After the MOBO startup screen, i get this message:

    "Sil 3112A SATALink Host Controller BIOS Version 4.2.10
    Copyright (c) 1997-2003 Silicon Image, Inc.

    Primary Channel: Drive not found
    Secondary Channel: Drive not found"

    How do i fix that? Does that mean something wont work correctly on my pc?

    Help please
     
  2. Cinders

    Cinders TechSpot Chancellor Posts: 872   +12

    Do you have SATA drives in those ports? If not you can disable the device in your BIOS. The Silicon Image device is probably an extra SATA controller card your motherboard manufacture put in for added value and is not your primary SATA device. Your motherboard chipset usually provides the primary SATA controller.
     
  3. MightyKing

    MightyKing TS Rookie Topic Starter

    Ok, I'm a little bit of a noob, but what is a SATA drive? Like at least how does it look like?


    And how do i disable the device in my BIOS?


    If I disable it, will my PC run normally?
     
  4. Cinders

    Cinders TechSpot Chancellor Posts: 872   +12

    What motherboard or computer do you have? I'll look up your manual and take a peek at your BIOS, so I can tell you exactly how to disable those ports. My best guess is that you don't have any drives connected to those ports or you'd notice some missing drives when you booted your computer. Disabling the device will not hurt your computer and it should speed up your boot time a bit. A PICTURE OF SATA PORTS.
     
  5. MightyKing

    MightyKing TS Rookie Topic Starter

  6. Roboboot

    Roboboot TS Rookie

    Hi,

    I just actually fixed a problem with that. It's an easy fix. Just go into the BIOS and look at the IDE Master/Slave part on the main menu and turn off the ones that dont have any drives on them. That will keep the message:

    "Sil 3112A SATALink Host Controller BIOS Version 4.2.10
    Copyright (c) 1997-2003 Silicon Image, Inc.

    Primary Channel: Drive not found
    Secondary Channel: Drive not found"

    from appearing again.
     
  7. MightyKing

    MightyKing TS Rookie Topic Starter

    I see, ok thank you for your help.


    MightyKing
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...