TechSpot

Blank Screen with No POST

By natekar
Jul 10, 2005
  1. My system: ASUS A7N266-VM, AMD 2000XP Processor, 80GB HDD, 256 DDRAM, Samsung CD Writer.......

    I was playing cube game. Suddenly screen became blank. Then I retarted my computer. Blank screen with monitor light blinking. My comp wont even post. i get no beeps no noise.

    I checked the monitor with another computer, it works fine. SMPS is ok as i have checked with anohter computer. I checked the RAM, it is OK.

    i opened up my case and saw that all of my fans are runiing. Motherboard light is on.

    This is the first i am facing with this type blank black screen. No POST, BIOS setup screen.

    I believe culprit is Motherboard or Processor. I don't have similar extra Motherboard to check the processor. Is it a way to know the culprit without having extra Motherboard.

    Is it become correct refixing the CMOS and jumper setting that I don't know correctly to do. I don't have extra heatsink. Whether I can use same heatsink for testing?

    Hoping for help from anybody. With thanks

    S. Srinivas Natekar
     
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Check your psu, it may well have failed. Just because the fans are spinning, and the mobo light is on, doesn`t mean that your psu is ok.

    Regards Howard :cool:
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...