TechSpot

BSOD - NDIS.SYS STOP 0x000000D1, HELP!!

By soku11
Jul 25, 2007
  1. Hello!!
    Firstly - sorry for my English - Im not good at it, especially when it comes to hardware, software & other PC stuff :)

    Recently Ive beeen seeing BSOD with error included in the subject of my thread. It happens most freaquent and only (I suppose) when Im on internet. Sometimes when Im watching some movies on youtube, sometimes when Im downloading something with uTorrent - generally speaking when I use it in rather high way. The error code is something like this (translated from Polish from Spy Events - administrator tools):

    Im also worried about other errors which this tool showed me. They happen always before this crash and BSOD. Their source is ACPI, and one of them looks smthg like this:
    In other 3 errors I can only see the difference in addresses: 0x70, 0xcf8.

    I also used dumpchk cause I thought that Ill be able to do it myslef, but I was wrong :/ These are few lines from this dumpchk on recent drop:
    Code:
    DUMP_HEADER32:
    MajorVersion        0000000f
    MinorVersion        00000a28
    DirectoryTableBase  00039000
    PfnDataBase         8055edc8
    PsLoadedModuleList  8055a420
    PsActiveProcessHead 805604d8
    MachineImageType    0000014c
    NumberProcessors    00000001
    BugCheckCode        000000d1
    BugCheckParameter1  000000b0
    BugCheckParameter2  00000002
    BugCheckParameter3  00000001
    BugCheckParameter4  f747d4ce
    PaeEnabled          00000000
    KdDebuggerDataBlock 8054c060
    MiniDumpFields      00000cff
    
    Please help me!! I cannot use my computer in normal way. I do everything to solve this problem. Thanks for every help.
    C U
     
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    What are your computer's specs? Try swapping your memory or testing memory first
     
  3. soku11

    soku11 TS Rookie Topic Starter

    See my profil for specs :) Yesterday i checked everything with BurnItTest and it failed because of cdrom error (i dont put anything in my cd-rom) everything else had no errors. I used also MemTest for a night (with uTorrent working in the background) and in the morning I saw other BSOD with something like: STOP 0x10000050 ... Today I got another 3 BSOD. 2 of them were 0x000000D1 NDIS.SYS, and one was 0x000000D1 NV4_mini.SYS or smthg like this:/ Do you have an idea what to do?? Maybe I should give you some of my minidumps?? C U
     
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    NV4_mini.SYS... NVIDIA driver fault. Ndis.sys Network Adapter card or driver fault
     
  5. soku11

    soku11 TS Rookie Topic Starter

    OK. I updated drivers of Video Card and all my network hardware. Now Im waiting for another BSOD. When it occur, Ill let you know by editing this post.
    C U


    Added:

    I had only one day without BSOD :/ It happened again about 10min ago. It was again NDIS.SYS...What to do now?? How to diagnoze it??
     
  6. soku11

    soku11 TS Rookie Topic Starter

    Nobody know?? Please help!!
     
  7. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Your motherboard is getting pretty old. It might be time to upgrade your total system. NDIS.sys is still a NIC or NIC driver problem no matter how many times it appears
     
  8. soku11

    soku11 TS Rookie Topic Starter

    Can you explain me what NIC is because I think I dont understand this...
     
  9. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    NIC= Network Interface Card or adapter. I don't know if your motherboard has a built-in NIC. Because of it's age, I don't think the NIC is built in. It may be a PCI card
     
  10. soku11

    soku11 TS Rookie Topic Starter

    Your talking about the card which let me connect with internet?? If so, I use external modem connected to the USB... On my mobo I have only graphic card and network card (Realtek)... I dont know if you mean it...
     
  11. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Yes the Realtek is an on-board NIC... Did you just get the USB connection? You might go into the motherboards bios and disable the Realtek card. See if this cures the BSODs
     
  12. soku11

    soku11 TS Rookie Topic Starter

    I only tryed to disable Realtek in Properties in 'My Copmuter'. I really dont know how to disable it by BIOS :/ I will later tak it out and then check BSOD. I can only add that after I had installed new drivers I got BSOD now so often then a week ago. Ill let you know what happens. C U
     
  13. soku11

    soku11 TS Rookie Topic Starter

    Yesterday I removed my Realtek card. And today I got another BSOD :/ Now it's like this:
    There is no link to ndis.sys :/ What to do now??
     
  14. garreg_ddu

    garreg_ddu TS Member Posts: 19

    Hi Soku11. You don't say which OS you are using, but if you are on Windows 2000 it may be worth while looking at a Microsoft Support link which details a known problem with W2K SP4 and has a hotfix for a similar error message. See http://support.microsoft.com/kb/840890. Have you checked the event logs to see if there is any more detail?
     
  15. soku11

    soku11 TS Rookie Topic Starter

    Today I got 2 more BSOD. They pointed again to NDIS.SYS. I took out one of my RAM block and put it in other slot. Now it seems fine, but BSOD are really randomly so I have to wait.

    My OS is Win XP with SP2. This link is not for me because I dont have anything like DRIVER_IRQL_NOT_LESS_OR_EQUAL on blue screen :/ I looked everywhere for help. Polish 4ums dont respond or dont know what to do :) All my drivers are updated. The only network device in my PC is USB modem Thomsson SpeedTouch330.

    Events log shows me only some system errors like this:
    Code:
    Error code: 100000d1, parameter 1 000000b0, parameter 2 00000002, parameter 3 00000001, parameter 4 f747d4ce.
    I think that there is one important thing in this which I wrote in my first post. Its an error with ACPI. I translated it into english in my first post. Is it normal error or should I be worried??
     
  16. garreg_ddu

    garreg_ddu TS Member Posts: 19

  17. soku11

    soku11 TS Rookie Topic Starter

    Thanks for link. So now I know that this is a normal behavior. Two days ago I switched slots of my RAM blocks and since then I didnt have any BSOD. So I think the problem is solved :) Thanks again for all your help and wasted time to write a post :p C U
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...