TechSpot

Can not enable System Restore in WindowsME

By Doc_80
Mar 19, 2006
  1. I can not enable sytem restore by unchecking this feature in Troubleshooting tab. After restarting PC the Disable System Restore box is still checked. I also found that there are no *StateMgr and Stmgr.exe options in Msconfig any more.

    As I checked the registry HKLM does not have references for those file. However they both exist in "C:\WINDOWS\System\Restore" but obviously not running on my PC now.

    Does anybody know how to fix the regestry manually in order to have these files shown up in MSconfig again. So I can enable/disable system restore when I need it.

    Appreciate your advice.

    Thks & rgds,
    Doc_80
     
  2. Peddant

    Peddant TS Rookie Posts: 1,446

    From here - http://www.mcse.ms/archive294-2005-6-1655857.html

    First try launching system restore directly rather than via the button in
    msconfig. There are many ways you can do this including:
    a) By launching system restore using the shortcut found at Start |
    Programs | Accessories | System Tools,
    b) From the link in Help & Support,
    c) By entering C:\windows\system\rstrui.exe in the Start | Run box and
    clicking OK, or,
    d) By directly double clicking the file rstrui.exe (Use Windows Explorer,
    rstrui.exe is in the windows\system\restore folder).

    If these confirm your previous findings then:
    Do you have at least 300MB of free space on the drive containing your
    windows folder?
    Is the *StateMgr entry still present and checked in MSConfig | Startup?
    Is stmgr.exe running? You can check this using either a process monitor
    such as WinTop or TaskInfo or by using MSInfo32 (Start | Help & Support |
    System Information) and checking for stmgr.exe in the section Software
    Environment | Running Tasks.

    If all of the above are OK then I think that the best way forward would be
    to remove the _RESTORE folder and allow the state manager to rebuild the
    necessary control files which have probably become corrupted. Delete the
    folder as follows:
    a) Boot to DOS using a floppy. Do NOT choose "Minimal Boot" from the menu
    when booting from a floppy but rather choose "Start computer with (or
    without) CD-ROM support" otherwise the ATTRIB command will not be
    available.
    b) At the DOS A:\> prompt, type:

    ATTRIB -H -S -R C:\_RESTORE
    then
    REN C:\_RESTORE OLDREST

    c) Remove the floppy
    d) Reboot your PC
    e) Delete the folder C:\OLDREST
    f) Check that an automatic system restore checkpoint was created.
    g) Finally adjust the space allocated to the restore folder:
    System | Performance | File System | Hard Disk and adjust the restore
    slider to your preferred setting. A figure of 2-300MB is normally more
    than adequate for day to day use allowing perhaps a week of checkpoints to
    be available although increasing this to perhaps 4-500MB for a few days
    during periods of large installs such Microsoft Office is advisable.

    It might now be a good time to test that system restore is working
    correctly. You can do this by performing the following test.
    a) Create a shortcut on your desktop to a file.
    b) Create a manual checkpoint
    Could you create a checkpoint?
    c) Delete the shortcut
    d) Restore your PC to the checkpoint you created.
    Was the shortcut restored? Did you see any error messages?
    e) Reboot your PC
    Was the checkpoint retained?
     
  3. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    winME is garbage. get rid of it.

    use 98SE or XP.
     
  4. Doc_80

    Doc_80 TS Rookie Topic Starter

    Hi Peddant,

    thanks a lot for your reply (greate reference). It worked for me.

    For the record - surprisingly I was able to delete _Restore folder and its content without booting in DOS. Apparently, attributes of these files were altered somehow when system restore configuration got corrupted. After that I recovered system restore by running rstrui.exe and by creating a new restore point. Now I have a brand new _restore folder with max size limit of 200mb (which is more reasonable comparing with 3 gb I got rid of).

    Thanks again for your help and good luck.

    Doc_80
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...