Can someone help with FQDN?

By rusta
Mar 24, 2008
  1. I'm trying to setup a mail server from my home and it's actually working ok, but I want to switch over to a static ip. My ISP asked me to email them my FQDN.

    How do I determine what my FQDN is?

    For example if:

    I have a domain ""
    I have MX record for ""
    My server name is "123mail"
    My server full name is ""

    Would "" be the FQDN of my mail server?
  2. HillJack

    HillJack TS Rookie Posts: 19 could be your fqdn, but mail should be an A record, while (in this example) if your server is really called 123mail, then imo, should be the fqdn.

    Keep in mind that you will need to create an A for too... Nothing like an invalid PTR for a mail server.
  3. jobeard

    jobeard TS Ambassador Posts: 9,148   +597

    Hilljack is correct.

    Remember, your email server (to be of any real value) must be accessible to
    the Internet. While you can rename it anything you like on the internal LAN
    (eg, that is basically the wrong thing to do; use one name for
    each resource.

    Stick with your domain; your local DNS should be the one
    to map the email server into a location ip address using as
    the name to some system in the DMZ or behind the infrastructure firewall on your lan.
  4. rusta

    rusta TS Rookie Topic Starter

    Thanks HillJack and jobeard, I appreciate the help. I think I understand it better now, but not sure. Have a few more questions if you have the time.

    jobeard what do you mean by

    Should I rename my mail server machine from "123mail" to "example" ? What do you recommend?

    Is a PTR record necessary? I thought that a MX record was all I needed.

    The reason I ask is becasue I have the mail server setup now and seems to be working ok and as far as I know there were no PTR records created.

    Here is some more info

    I have a SBS 2003 and Exchange setup. 1 NIC with local router. There is 1 website hosted on it. Exchange is setup to use my ISP's email sever as smarthost. If I want to use OWA, I type in hxxps:// If I use an email client, I use for both incoming and outgoing servers. This works ok, but I had to change the default SMTP port number from 25 to 587.

    I know this is not the correct way to set it up, that's why I am getting a static IP with no ports blocked.
    The goddady settings below are probably not correct either.

    According to what HillJack said, I should add another A record for
    Would this be correct?

    Below is my settings on godaddy.

    A (Host)

    Host Points To

    CNAMES (Aliases)

    Host Points To
    www @
    ftp @

    MX (Mail Exchange)

    Priority Host Goes To
    0 @


  5. jobeard

    jobeard TS Ambassador Posts: 9,148   +597

    I'm validating Hilljack's comment; would be fine while is nonsense.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...