can u help with my dvd rom drive?

By Maynard
Jan 20, 2007
  1. i have had this pc since april 06 and the dvd om worked fine....the other day i put in a dvd and it didnt play......checked my computer and the drive isnt showing up.....checked device manager and there is a yellow ! ........i tried to update driver...didnt work.....i uninstalled the dvd rom and rebooted the pc.....didnt work.....

    called emachines (dont say it) and they did some bs that didnt work and decided to send me a new dvd rom since its under warrenty.....i got the new dvd rom today and installed it....still having the same problem

    any help
  2. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    If you have confirmed the cable connection (bent pins etc.),Jumper setting, then it may be the Firmware version needs an update.
    Also you said the Computer does not see the drive.Do you mean in CMOS. If it is not there try a CMOS reset.
  3. Maynard

    Maynard TS Rookie Topic Starter Posts: 18

    its there in the cmos.....its not there when i look in my computer, its normally the G drive....the icon isnt there........jumpers and pins are good.....

    i just DL a firmware update from techspot and when i clicked to run said the firmware is only good for the

    Lite On DVDRW SWH 1635S

    which is odd, because thats the exact drive i have.......its says drive not detected
  4. Maynard

    Maynard TS Rookie Topic Starter Posts: 18

    now emchines says i need to do a full system recovery to reinstall te drivers......which im not about to do......

    i dont understand this problem.....i uninstalled the dvd drive and rebooted the system to install the drivers again.....but that didnt work.....i downloaded the firmware update but when i click the exe file it gives me a pop up saying the file is only good for the Lite On DVDRW SWH 1635S, no matching drive detected.......that makes no sence because that is the dvd drive i have in my pc....and there are no other dvd it possible i am doing somthing wrong when tring to run the flash file? i assumed after unzipping the file that i would just click on the .exe file to run the firmware that incorrect?

    i ran a full virus scan last night to be sure no virus was causing the problem........

    does anyone have any ideas? thanks for the help
  5. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,233   +234

    Your motherboard's IDE controller may be partially bad. This is highly unlikely in most computer's, but with Emachines ANYTHING CAN HAPPEN! If the DVD is on it's own Secondary IDE controller, try installing it as a Primary Slave with the hard drive as the Primary Master. You can also try resetting the CMOS or bios
  6. Maynard

    Maynard TS Rookie Topic Starter Posts: 18

    ......i have a hard drive as primary master and another hard drive as the primary slave

    i have the dvd drive as the secondary master...allthought the jumpers are setup in the cable jumper position.....this is how the old drive was set, and when i got the new drive, it was pre set this way too.....

    should it be set to master?

    how do i reset the CMOS and BIOS? i have a option to use optimal settings in my bios settings....i did that already....not sure if its the same as a reset......

    what about the cmos?
  7. Teaser261

    Teaser261 TS Rookie Posts: 121

    To reset the CMOS, there is either a jumper to move when the machine is off(check the mobo manual) or pop out the battery for a few seconds. I would also set the dvd jumper to Master. Everyone says nat to use the cable setting. Thereis also a fix to restore the drive that someone on techspot showed me once , but I can't remember the file I saved it to( I'm still looking).
  8. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    You do not need to reset your CMOS since the drive is recognized there. The problem should be in the OS
    The jumper MUST be set to Master. Cable select only works properly if you are populating the channel with 2 drives and you are using a newer version cable.
  9. Maynard

    Maynard TS Rookie Topic Starter Posts: 18

    im going to try the master setting......what i dont understand is that it has worked fine with the cable setting since i bought the pc......i dont understand why it would stop working all of a sudden

    but i will post back after i try the master setting.....thanks for the help guys
  10. Teaser261

    Teaser261 TS Rookie Posts: 121

    When it comes to hardware and hardware conflicts, PC's are very mysterious , stubborn,and spur of the moment. Like my
  11. Maynard

    Maynard TS Rookie Topic Starter Posts: 18

    changing the jumper to master didnt work either...still the same problem.....

    yellow ! and i cant update the firmware......
  12. raybay

    raybay TS Evangelist Posts: 7,241   +9

    Your symptoms are all typtical of a failed DVD drive... You have easily have brand new DVD drives that are defective. Can you borrow another known working drive to test to see what is up.
  13. Maynard

    Maynard TS Rookie Topic Starter Posts: 18

    i could....but emachines sent me a knew dvd drive...i installed it and i am still getting te same problem
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...