cannot detect a master drive

By uglyfido
Jan 21, 2009
  1. Hello, I am building my pc and have run into a snag. I have my hdd set to ms and I have it on placed on the cable correctly and also plugged into the mobo correctly as according to my mobo's manual. The problem is that when it boots and detects the IDE's it come's up fine, but as soon as the BIOS loads it cannot detect a master drive. Any help would be appreciated. If more info is needed to help me fix this please let me know. Thank you.
  2. tastegw

    tastegw TS Enthusiast Posts: 188

    im not 100% sure i can help you here, but i will try.

    on your IDE drives, did you set the jumpers on the back of them correctly?

    edit: it should look something like this, but not exactly like it

  3. uglyfido

    uglyfido TS Rookie Topic Starter

    Yes, I have it set to master correctly. I have ruled out a jumper issue.
  4. tastegw

    tastegw TS Enthusiast Posts: 188

    i dont know what to say then.

    if its set as master, and the ide cables are in the master slot, and bios isnt reading it. it could be a bad cable connection or bad cable itself, or bad hard drive or bad mobo.

    i do recommend the next mobo you buy, be sure it has sata connectors on it.
    and get a hard drive that supports sata. its so eay to set-up, its allmost like plug-n-play,

    but as for as your current situation goes, somebody with more knowledge than me will have to help you out.

    good luck.
  5. uglyfido

    uglyfido TS Rookie Topic Starter

    My current mobo actually supports SATA. I i am using the IDE as a temporary drive until I can get a SATA drive. I know the SATA is much easier to use, it is just more money, which is a slight problem a the moment. Hopefully I can get the SATA drive soon and solve my woes, or....someone else can chime in and try to help. :)
  6. LinkedKube

    LinkedKube TechSpot Project Baby Posts: 3,481   +44

    Is there an option in "boot," area in your bios to change the order, that may be an issue, OR I know there was an option in my old Asus board in the harddrive section where you can set it to sata or ide/sata. It should be on the screen that shows your devices(hdd,s/cd drive.)
  7. k.jacko

    k.jacko TS Rookie Posts: 493

    try clearing the cmos as well.
  8. uglyfido

    uglyfido TS Rookie Topic Starter

    The cmos was definitely cleared. I have the boot order setup to have the cd-rom boot first so that I can install windows. I tried having it boot the hdd first, but it didn't change anything. I also know the cable is good. I think I am getting ready to just stop and wait until I can get a SATA drive. Besides I'm getting a new laptop very in the next couple of days so it won't be such a bad wait. Thanks for all of the ideas though. I think i will stick around and utilize these forums some more. :)
  9. AdriMagnon

    AdriMagnon TS Rookie Posts: 20


    I'm a little confused...

    The BIOS loads first so that if the first part of your sentence is correct "when it boots and detects the IDE's it come's up fine," then I don't think the second part can be true "as soon as the BIOS loads it cannot detect a master drive."

    By BIOS do you mean Operating System? If so, which OS? If you hit DEL or whatever the key is to go into the BIOS to change it do you see the correct drive (name/size/space) in the BIOS screen options? What channel is it on? Channel 0 Master? A bad logic board on a hard drive could make a drive show up but it would be off on size and make/model.

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...