Cannot see certain computers on the network

By mudmin
Jan 28, 2008
  1. I'll try to be as descriptive as possible. Certain computers that I have simply cannot be seen on the network. I've got 8 computers on a 48 port 10/100/1000 switch that's plugged into a 2Wire Gateway. All are running XP Pro. 3 of the computers cannot be seen on the network, although they can see the "working" computers and browse the internet.

    Here are the things you might ask me to do that I've done.
    1. I've tried with and without NetBEUI installed
    2. I've completely turned off Windows Firewall and do not have any other firewalls installed.
    3. These 3 pcs all have a fresh xp install.
    4. They are all on the same workgroup
    5. A folder on each is shared
    6. I've tried with Simple File Sharing on and off
    7. I can ping all the computers by both ip and name
    8. The computer browsing service is started
    9. I've even resorted to using the networking disk to make SURE all the settings were the same on all computers.

    I'm baffled. Any ideas, PLEASE?
  2. jobeard

    jobeard TS Ambassador Posts: 9,156   +598

    >All are running XP Pro

    SP1 or SP2?

    > I've completely turned off Windows Firewall and do not have any other firewalls installed.

    this is not as effective as one would assume. ALL firewalls must enable
    Ports 136,445 to allow the systems to be seen.

    in addition, LAN address x.255 will be used for the broadcasting.

    Using COMODO FW and having another system on the LAN, I see access on
    ports 139 & 445 when attempting to Map Network Drive->Browse->Workgroup

    There is a security hack that inhibits Share enumerations -- have you run any
    lockdown scripts?
  3. tipstir

    tipstir TS Ambassador Posts: 2,383   +105

    On by blog there is a section for pcs can't be seen on workgroup.. Just follow those steps.. I had the same problem once I fixed it then all the pcs were appearing.

    I have more stuff to add to my network page on the blog but you should see the info..
  4. jobeard

    jobeard TS Ambassador Posts: 9,156   +598

    very nice :)

    I suggest that
    You need to make sure SSDP is enabled and started (auto)
    You need to make sure UPnP is enabled and started (auto)​
    present security issues and that they are not necessary for accessing a workgroup
  5. tipstir

    tipstir TS Ambassador Posts: 2,383   +105

    Yep those are enabled so you get the router popup message in your system tray when you connect to the router directly There is also one in network connections where you can right click and invoke the router to connect to it. This can be done under XP. All of this stuff is disabled by default. Good idea to have it enabled. If it doesn't work you need to visit my blog. There are some more info there too.
  6. jobeard

    jobeard TS Ambassador Posts: 9,156   +598

    but that's unnecessary. Using DCHP on the router, allowing port 53,67 makes SSDP and
    UPnP not necessary at all. Saves two system services in the startup and slams the
    security issues for both SSDP and UPnP.

    Oh well -- to each is own :)
  7. mudmin

    mudmin TS Rookie Topic Starter

    Didn't work :(

    Tipster, I went through and followed your instructions to the letter from. Everything was exactly where you said it would be and there's no problems there, I still can't browse the network.

    It is definitely a BROWSING issue because I can right click My Network Places and tell it to search for a computer, type in the name of any of the 3 "non-working" pcs and it will find it quickly. I just can't browse to it from MNP.

    It's a big frustration when trying to get there from my XBOX media center, although the searching thing has provided a workaround. I just still don't get what's going on.
  8. tipstir

    tipstir TS Ambassador Posts: 2,383   +105

    Last thing you can try is this...

    What type of router you have there? I know it's a major problem to have all the PCs in the network able to see each other. If one is out of sync then boy it can try network administrators crazy. You have some other issues going on you might have over looked.

    Are you sync data between these systems? Check My Network Places and see if there is any old data showing for old map drive or shared network names. You need to get those removed.

    The last step would be to stop everything you got...

    1. Remove all network drivers from each PC. Then have windows re-install them when you reboot the system. The way I would do this is:

    a; remove the drivers
    b: shutdown the PC

    Repeat 1 for all PCs on the network..

    2. Shutdown modem for internet as you don' t need that up and running for this project.

    3. Restart the router, but don't reset the router. There is a difference. Make sure you diable router logs. These just slow down the router. Shutdown the main router and anything you got for switches bridges and wireless devices including the xbox360 an etc..

    4. Now start up the router and start up the closest PC to the router. Now with that PC make sure you can access the router and the router can see your PC. Make sure My Network Places shows the router if you have that option enabled. and you can see your PC listed.

    Another thing you can do. Which I do all the PCs have MAC address that go with the network card has and ID tag. So each PC with it's MAC address and assign only to access the network. The Xbox360 will have one too. So this protocol would be Mac address filtering.

    Again you don' t have to do that but I would recommend you doing that. Another features you can do is DHCP Static Client IP. Once the DHCP has found your PC by IP and mac address I add those PCs to my DHCP static client IP. So for now on no matter if the PC is on or off the router will assign that IP addres to that device always. Locks it in! Good measure. Dlink routers have this feature.

    5. Now turn on the DSL or Cable Modem you have there. Make sure the router does see it and it gets connection. Take the first PC you have running and make sure you can get on the internet.

    If you can an everything is okay now... Goto step 6 or fix your problem if you can't get on the net.

    6. Turn on one PC at a time, but make sure like you did with the first one you get:

    1. DHCP
    2. Router does see the PC
    3. You can see the PC in My Network Places under Workgroups
    4. You can browse the first PC okay and the first PC can browse you
    5. You can get on to the internet..

    Repeat this process for all your PCs and equipment but take your time and do it slowly. You need to weed out the problem PC or find out what's causing your browsing problems.

    Before you got out and replace:

    network cards
    network wireless adpater cards
    redo OS..
    or remove users profiles to make them work again..
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...