TechSpot

Cannot share printer or files on wireless network - internet OK.

By Absinthe Minded
May 12, 2007
Topic Status:
Not open for further replies.
  1. Hello all,

    I'm trying to set up file and printer sharing on a desktop and laptop with xp on both. The internet connection is fine, shared through a Belkin router. The router is wired to the desktop and the laptop connects wirelessly.

    If I try to add a printer to the laptop via 'Add new printer' I cannot browse the network - I get a message saying "Mshome is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions."

    Also, I can't share files between the two computers.

    Any help would be much appreciated.

    If you need more info, please ask - I'm not very good at networking.

    Thanks,
    Nick.
  2. xxdanielxx

    xxdanielxx Newcomer, in training Posts: 1,214

    have you run the network setup wiz if so are they both on the same workgroup
  3. Absinthe Minded

    Absinthe Minded Newcomer, in training Topic Starter Posts: 29

    Hi daniel,

    Yes, I ran the network wiz but I'll re-run it and make sure the workgroup names match.

    Many thanks, I'll get back to you soon - it's not actually my PC so I'll have to check it tomorrow.

    Cheers,
    Nick.
  4. justone

    justone Newcomer, in training Posts: 23

    Did you share the printer at your desktop??? Before you install the printer thru network or sharing, share the printer first.
  5. Absinthe Minded

    Absinthe Minded Newcomer, in training Topic Starter Posts: 29

    justone, thanks - I'll check that today.

    Cheers,
    Nick.
  6. jobeard

    jobeard TS Ambassador Posts: 13,369   +302

    all systems which access a SHARE or share a resource need to allow specific
    ports to be opened. If you use the freebe firewall with XP
    (suggest you do some homework on this subject), then on the Exceptions Tab
    just enable Print/File Sharing.

    Otherwise, you need ports 135,137,139,445 to/from ONLY your lan address range.

    Frankly, I find it easier to get Folder Shares running first as there's no need to
    install print drivers and it's quick to see success/failure.
  7. Absinthe Minded

    Absinthe Minded Newcomer, in training Topic Starter Posts: 29

    Hello all,

    Thanks, joe for your comments - I will read up on the firewall and try to check out the ports.

    There have been some developments today:

    I found that I could ping the laptop from the desktop using both name and IP but couldn't ping the desktop from the laptop (using name or IP).

    The desktop and laptop are using Norton 2005 and Norton 2006, respectively so I disabled the Norton firewall on the desktop and found then that I could ping the desktop from the laptop (with name and IP). After that I got onto the laptop and went to Printers and Faxes/Add New printer and then searched for a printer on the network. Success, the printer was listed and I selected that and then printed a document via the laptop.

    Then I toddled off to My Network Places on the laptop and, hey presto - all the shared files on the desktop were listed. Trouble is, if I try to open a folder there, I get the following message:

    \\DESKTOP\My Documents is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

    Not enough server storage is available to process this command.


    I looked at My Network Places on the desktop and all the shared laptop files were listed - if I click on a file, I can open it just fine.

    So, to summarise:

    I can access the printer via the desktop (to which it is connected), or on the laptop (via the network).
    I can use the desktop to access the shared files on the laptop.
    I cannot use the laptop to access the shared files on the desktop (and one of these is the shared folder). This is where I get the error message in bold, above.

    Thank you all for your patience - you're all very kind!

    Nick.

    Edited to say that I have admin rights on both desktop and laptop.
    Edited again to ask do you think that this: http://support.microsoft.com/default.aspx?scid=kb;en-us;177078 might be the answer?
  8. jobeard

    jobeard TS Ambassador Posts: 13,369   +302

    the firewall on the desktop is inhibiting PING replies
    the system names comes via port 135. data flows on ports 139 OR 445

    the MS KB article might be involved here -- how much ram do you have installed AND what is your pagefile size setting?
  9. Absinthe Minded

    Absinthe Minded Newcomer, in training Topic Starter Posts: 29

    Hello jo and thanks for your continued help, as usual!

    I'm not really sure what the port values mean, or how I can view / change them, so some more info would be good if you don't mind.

    As for RAM and page file settings (virtual memory, I assume), I have emailed the owner of the computer with details on how to look these up and I'll get back to you as soon as I find out.

    Thanks again,
    Nick.

    Edit, re: the ports - I'm off to do my homework on the winxp firewall.
  10. justone

    justone Newcomer, in training Posts: 23

    \\DESKTOP\My Documents is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.


    sometimes i'm encounter about that problem and im doing is to remove the share and back to share the document and then presto, i open the files thru network... just try if it helps for you.
  11. Absinthe Minded

    Absinthe Minded Newcomer, in training Topic Starter Posts: 29

    Hi justone,

    Thanks for that - I'll definately give it a go and let you know if it works.

    Cheers,
    Nick.
     
  12. Absinthe Minded

    Absinthe Minded Newcomer, in training Topic Starter Posts: 29

    jo,

    Here's the info you needed (as per 'System Properties'):

    RAM is 763 MB
    Paging file for C: is 336 - 672.

    Hope this helps.

    Cheers,
    Nick.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.