Can't disable write-behind caching

By aec618
Mar 31, 2008
  1. Hello all--

    I recently solved a driver problem that wasn't allowing me to play a game (FlightSim X Demo), only to find another problem. After install, the game actually let me fly--once--:( then I started getting popup errors that Delayed write to C:\Mft failed. When I restarted the computer, it went through all the CHKDSK stuff to fix problem files, which also uninstalled the game. Error messages went away but resumed after I tried installing the game again. So I did some online checking--Windows knowledge base says this can occur with lots of big files being copied, large hard drives (>100GB), and RAID arrays. It recommended increasing the PageFile size so the page file won't run out of room with large/big file transfers, but mine was already set to the recommended setting of FFFFFFFF. Which brings me to my current issue:

    The other recommendation was to disable write-behind caching. I tried this, but the options on the relevant window of the Control Panel are all greyed out. So I can "see" the option I need to change but Windows won't let me change it.

    Does anyone know how I can tell Windows to let me change this so that write-behind caching is disabled? Is there a setting in the registry I can modify?

    I have a RAID array, two 160GB SATA drives in mirror mode. Would this be preventing me from making the change? (i.e. is the RAID driver taking control of this feature away from me?)

    Would doing a repair install of Windows be helpful? I'd hate to go through all that if it won't.

    Thanks much!
  2. aec618

    aec618 TS Rookie Topic Starter

    Well, I solved my issue; got some advice from some folks elsewhere; thought I'd post what I learned, in case it helps the next guy down the line!

    OK, so after staying up till 3AM wrestling with this, I think I've at least acheived system stability. In retrospect, I suspect the Via RAID driver doesn't work/play well with others, because now that the two hard drives are no longer in RAID mode, all seems to be well. I'll know for sure if I can install Flight Simulator X Demo tonight without getting a Delayed Write Failure or a BSOD. but so far, looks good.

    Lessons learned:
    --Apparently SATA drives are managed by the same driver that would manage a RAID array if I had one. (since the system boots right to a BSOD whenever I uninstall the RAID driver and reboot!). so apparently with an internal HDD, at least a SATA drive, there is no way to turn off write-caching. at least none that I can find.

    --Looks like at least in this case something I did to improve fault tolerance (RAID mirror array) introduced instability and decreased fault tolerance. go figure.

    --I did note that on my USB External IDE HDD, I DO get the option to turn off the write-behind caching--I guess since it's a removable drive, it lets me choose.

    Things I tried that DIDN'T work:

    --Using DSKCACHE.EXE utility from Microsoft (supposed to allow you to set/unset caching from the command line)

    --Registry tweak to add a subkey to the parameters of each SATA drive to not "UseWriteBehind" caching.

    --Removing the RAID driver entirely from Windows (it's needed to run the SATA drives, even if not in a RAID array configuration)
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...