TechSpot

Can't play Age of Empires III online

By C_Conqueror
Nov 12, 2005
Topic Status:
Not open for further replies.
  1. I use to be able to go online and play age of empires III fine but now when I click on ESO it starts to connect but then stops and says ESO does not support this game version I checked for updates and it says that I am up to date. I have tried reinstalling the game and that didn't work. Please help me
     
  2. spartanslayer

    spartanslayer TS Rookie Posts: 464

    well

    You may have spyware on your computer. Download Microsoft Anti-Spyware and see what shows. Or you may have installed a bad update. Try reinstalling the game and going online without getting updates. Hope this helps.
     
  3. C_Conqueror

    C_Conqueror TS Rookie Topic Starter Posts: 217

    I know that I don't have spyware and I think I found out the problem, it is ESO problem because I went to agecommunity.com they explained that it was something to do with there servers so I will just wait it out until they get it running.
     
  4. sphinx

    sphinx TS Rookie Posts: 17

    They may be resolving this (along with some other bothersome things in the game, like that stupid sound stuttering problem) with the new patch thats set to be released very soon.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.