TechSpot

Can't see logon screen in redhat 9

By wellenberger
Dec 4, 2004
Topic Status:
Not open for further replies.
  1. I haven't worked with Linux in a couple of years, so I guess I'm considered somewhat new. I just installed Redhat 9 as the only operating system on a desktop. During installation I think that I set the monitor resolution too high. Now when the system is finished booting, the screen will flash a couple of times then go black.

    I have seen different suggestions on how to change the settings, but I can't seem to get the system to do anything without being able to login. I figure that if I change the login screen to "text" then I should be able to do something.

    I wanted to try this system before putting it on my laptop, but it's just sitting there now driving me nuts!

    Any ideas on things to try?

    Thanks
  2. Didou

    Didou Bowtie extraordinair! Posts: 5,899

    Hit CTRL+ALT+F1, log in as root then type redhat-config-display.
  3. wellenberger

    wellenberger TS Rookie Topic Starter

    I tried the CTRL+ALT+F1 and I get sent back to the boot screen with the 'Starting firstboot' option at the bottom. I've let it set there for 5 minutes with nothing different happening; I've tried entering my password' I've tried hitting ALT+F2 (something I saw somewhere else, thought I'd give it a shot). It's just sitting here doing nothing but teasing me now.

    Where do I go from here?

    Thanks :bounce:
  4. Nodsu

    Nodsu TS Rookie Posts: 9,431

    At the boot prompt (either LILO or GRUB), boot into "safe mode" (does RH9 have that) or add a kernel parameter "single". You should get a command prompt. In there edit the X configuration file to use a lower resolution.

    Or just reinstall..
  5. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,916   +9

    You could try pressing ctrl+alt+numpad plus or minus keys simultaneously too, that cycles different X server screen resolutions if there are any available.

    ctrl+alt+backspace kills X server, but I guess you set it to boot into graphical mode automatically, so xdm starts it again. Therefore you'd want to type 'telinit 3' as root to start the computer in textmode.

    By default RH9 starts six terminals, so you can press alt+F1 to alt+F6 to cycle between them, ctrl+alt+(F1-F6) if coming from X session.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.