CD/DVD Drive will play DVD's but not CD's

By tevans
Feb 9, 2007
Topic Status:
Not open for further replies.
  1. I have a compaq presario 900 laptop with a H*L Data Storage (Hitachi/LG) CD-RW/DVD Drive. A DVD will play every time no problems, however any cd will not, even cd's I have used in the past will no longer play. When inserted it makes clicking sounds like it is tring to read it but after 30 sec or so it just stops. When I click on the drive it does not show a disc is there, just nothing. I've had this prob for over a year and am getting frustrated...aaarrrhhh . I asumed the drive was bad so I bought a new one (identical) but it did the same exact thing. This would logicly suggest that its not a hardware prob. Driver says its up to date, diagnostics show everything is installed and working properly. Any help would be appreciated. I also deleted the high and low filters in the registry, that did not change anything. Problem possibly started after reloading Roxio 5.0 but not sure.
  2. mailpup

    mailpup TS Special Forces Posts: 8,410   +213

    In the Device Manager try uninstalling the channel to which the optical drive is connected under IDE ATA/ATAPI controllers, reboot and let Windows reinstall it.

    If that doesn't work, try running this little utility from Roxio: Click here. There are two different versions depending on whether you have Roxio currently installed or not. I've used it when my Roxio Easy CD & DVD Creator 6 failed to recognize my optical drives. My problem may not be exactly like yours but the utility might still work. It is a standalone utility that doesn't have to be installed. Just double click the .exe file.
  3. tipstir

    tipstir TS Ambassador Posts: 4,596   +79

    Clicking sound could be the unit is bad, or it just can't read the disc. When last did you clean your drive? They do need cleaning. Just buy a CD/DVD cleaner all that is is a CD/DVD with tiny brushes that spin over the laser head to remove the dust. But if you clean it and it still does it you might have to repace the drive with an external unit. These are cheaper now then before. You would hook that up to USB 2.0.
  4. gsimcakoski

    gsimcakoski Newcomer, in training

    Same problem

    I have the exact same problem as tevans did. It ocurred right after I re-installed Roxio 5.0. Like he tried, I used another working drive and it does the exact same thing. so tipster has a bad suggestion. ANYONE know what is going on and how to fix?
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.