Certain paths and folders inaccessable across network.

By Skutty
Dec 11, 2007
  1. Hey Techspot,
    The other computers in my network have trouble accessing certain shared folders on my main computer. I have three drives installed, C: my OS drive, and D: and B: file drives. My C: Public folder, another folder on C: and my entire D: drive have been shared for a long time, and are the only paths the other computers can access. Anything I try to share now (except stuff on the D: drive, since the entire thing is share-enabled) will return the "is not accessible. You might not have permission to use this network resource." error.
    I can understand why a computer in it's entirity wouldn't be accessible across a network, but as to why certain locations wouldn't work - some on the same drive as locations that do work - I'm at a loss.
    Thanks in advance!
  2. Skutty

    Skutty TS Rookie Topic Starter Posts: 46

    The edit button isn't working so:
    I forgot to mention, all the computers are running Vista Home Premium or Ultimate, all on an ethernet lan with a Belkin router.
  3. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    There are two layers of permissions on network shares.
    The permissions on the share itself and the filesystem permissions on the individual files and folders. Make sure that you have enabled access for the remote users in both of these.
  4. Skutty

    Skutty TS Rookie Topic Starter Posts: 46

    Thanks Nodsu.
    I'm not sure I understand, I'm assuming the individual file and folder permissions are the options found under "Right Click > Share...", where would I find the other layer you speak of?
  5. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    The Share permisions are, well, the share permissions. File and folder permissions are under "security".

    You do not get the security tab when you have crippleware called XP Home or you are using the FAT32 filesystem or you have enabled Simple File Sharing. All of the above are a bad idea :p
  6. Crazy

    Crazy TS Rookie Posts: 139

    In short, disable "simple file sharing", you can find it under map options.

    then, right click on the folder/partition you want to share => go to sharing, share it, go to permissions and add "Everyone"(click add, type everyone and enter).
    Give everyone all rights.(Don't worry, NTFS rights will limit the accual access to the folder).

    Now go to security. Add the user you want to give access, f.e. take "everyone", and give them read rights.

    Now anyone who browses to that folder will have read rights.

    The reason I gave the group "Everyone" all rights on the share tab is because those arn't the "real" rights the group will get. You can see the "share" tab as "a way to get to the accuall rights". Those are done by the NTFS rights.

    Most sharing problems are caused by not applying the correct permissions.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...