Compaq Presario R4000 power light is blinking after using it more than 15 minutes

By deluxman
Dec 24, 2007
Topic Status:
Not open for further replies.
  1. Hello tech guys out there!
    I am having this issue with my Compaq Presario R4000. Whenever I have been using my laptop for more than 15-20 min, the ac adapter will not charge propertly. I will keep blinking on the power light as well as the start buttton light. But if I were to turn off the laptop and plug in the AC, it will charge normally again. Any idea what would be causing this issue?

    I am thinking it could be motherboard issue that controls the charging but it is really wierd. Anyone had this issue before, please share with me how you resolve it? It might also be the DC port.....

    Any comments or suggestion would be appreciated.

    BTW, I am also looking for 2gb ram PC 2700 for my laptop. If anyone has these for sale, please email me at jllaksmana@verizon.net

    Thanks!
  2. chamillitarysk8

    chamillitarysk8 Newcomer, in training Posts: 168

    is the computer new? and do you know anyone that has a adapter like yours so you could make sure it's not the adapter
  3. deluxman

    deluxman Newcomer, in training Topic Starter Posts: 61

    Unfortunately no one has the same adapter as mine. Therefore I could not tell.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.