TechSpot

Compaq sr1401nx device drivers... why are they not on the site?

By pyromaster114
Apr 13, 2009
  1. Okay, so my friend brings over his crappy compaq desktop.
    Lo and behold, he has a bunch of crap on it, so we settle on wiping it.
    I go to the website to get the drivers for it (http://support.hp.com) and I put in the model number and all, and it tells me that there aren't any drivers for it.
    There are several random downloads and stuff available, but no drivers that we need like the video card, chipset, etc.

    I managed to collect most of the drivers by scouting around the internet and looking up the motherboard model and all... but I haven't found one driver, and it's being quite illusive:
    The media card reader driver.
    So the media card reader doesn't work as of now, and neither does the USB port on the front of it (which I guess is part of the device, so it's not going to work without the driver...)
     
  2. AudioVayne

    AudioVayne TS Rookie Posts: 99

    Have you tried the vendor and Device ID?

    http://www.pcidatabase.com/

    Go into device manager, Right click the device that needs a driver and go into properties. Click the 'details' tab and copy the 4 digits from the 'ven' and the 'dev' and track em down on ^^^ that site. Sometimes there's a link or at least identifying the chipset ID so you know what to look for...
     
  3. pyromaster114

    pyromaster114 TS Guru Topic Starter Posts: 246

    Thanks, I'll have to try that...
     
  4. pyromaster114

    pyromaster114 TS Guru Topic Starter Posts: 246

    There's a problem with looking up the device id thing... it doesn't show up in the device manager evidently...
    I don't know why... but it doesn't.
     
  5. AudioVayne

    AudioVayne TS Rookie Posts: 99

    What do you mean? You click on each device when the list has been expanded...

    Say:

    [+] Other Devices

    [-] Other Devices (!)
    Other Device (!) <----- That one
     
  6. pyromaster114

    pyromaster114 TS Guru Topic Starter Posts: 246

    No, I mean the card reader on the front doesn't work, and there ARE no unknown devices or 'other devices' listed in device manager.
    It's like as if the device doesn't exist... but it's clearly plugged in... and it worked right before we wiped the disk of XP home edition in favor of putting Pro on there...
     
  7. AudioVayne

    AudioVayne TS Rookie Posts: 99

    Was the card reader installed factory or afterwards? There's nothing for a card reader on HPs site regarding your PC...

    Try disconnecting it and plugging it in again...

    It should plug into the USB pins...And if the front USB ports are plugged in try disconnecting them for now...
     
  8. pyromaster114

    pyromaster114 TS Guru Topic Starter Posts: 246

    The issue with this computer is that the HP site says pretty much absolutely nothing about drivers for anything really.
    As far as I know, the card reader was factory installed.
    I will try messing with it and try unplugging it / plugging it back in.
     
  9. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...